Bug 863063 - API changes between JON 3.0.1 and JON 3.1.0
API changes between JON 3.0.1 and JON 3.1.0
Status: CLOSED WONTFIX
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server (Show other bugs)
JON 3.1.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: JON 3.1.2
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 07:10 EDT by Lukas Krejci
Modified: 2012-11-06 16:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 16:03:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
api-check-4.4.0.JON310GA-against-4.2.0.JON.3.0.1.GA.txt (41.99 KB, text/plain)
2012-10-04 07:10 EDT, Lukas Krejci
no flags Details

  None (edit)
Description Lukas Krejci 2012-10-04 07:10:03 EDT
Created attachment 621568 [details]
api-check-4.4.0.JON310GA-against-4.2.0.JON.3.0.1.GA.txt

Description of problem:
Since this was not done rigorously during the JON 3.1.0 release, I've locally augmented the JON 3.1.0 build with the support for api checks using Clirr and ran the check against JON 3.0.1.GA.

The results are attached. I don't think all of them represent a real problem but at least the one mentioned by bug 861434 is:
Comment 1 Larry O'Leary 2012-10-08 20:10:08 EDT
There seem to be quite a few changes that will have negative impact on plug-in compatibility. 

Additionally, there are many changes to domain objects that will impact both plug-ins and client code running against the remote API.
Comment 2 mark yarborough 2012-11-06 16:03:12 EST
See https://bugzilla.redhat.com/show_bug.cgi?id=873866 for 3.1.2 equivalent (to perform same test for 3.1.2)

Note You need to log in before you can comment on or make changes to this bug.