Bug 863065 - [DOC] Disabling SELinux on RHS nodes is not listed in prerequisites of installation guide
[DOC] Disabling SELinux on RHS nodes is not listed in prerequisites of instal...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: doc-Installation_Guide (Show other bugs)
2.0
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Anjana Suparna Sriram
Sudhir D
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 07:15 EDT by Gowrishankar Rajaiyan
Modified: 2015-04-10 03:12 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-10 03:12:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gowrishankar Rajaiyan 2012-10-04 07:15:58 EDT
Description of problem:
I was going through installation guide of "Red Hat Storage 2.0" and couldn't find any info saying "you must disable SELinux" as a prerequisite.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Anjana Suparna Sriram 2012-10-04 07:24:34 EDT
The looks of this bug mentions that this needs to be updated in the Prerequisites section in the Installation Guide. 

http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Storage/2.0/html/Installation_Guide/chap-Installation_Guide-Test_Chapter.html#sect-Installation_Guide-gssa_prepare-prerequisites_1

Vijay, could you let me know why users need to disable SELinux? Also should this go into the guide as a note or just as a bullet point after Logical Volume Manager.
Comment 3 Anjana Suparna Sriram 2013-03-27 12:16:33 EDT
 ISO installation has selinux disabled by default. Hence, closing the bug.
Comment 4 Gowrishankar Rajaiyan 2013-03-27 14:22:26 EDT
We support booting from PXE. Ref: https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Storage/2.0/html-single/Installation_Guide/index.html#sect-Installation_Guide-Install_RHS-boot_frm_pxe_1

SELinux is disabled by default "if ISO is directly mounted for install", for all other ways, ks in initrd is not used. 


Moving back to ASSIGNED to have this documented.
Comment 5 Anjana Suparna Sriram 2013-03-28 04:44:08 EDT
Based on the recommendation, the documentation has been updated and is available at: http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Storage/2.0/html/Installation_Guide/sect-Installation_Guide-Install_RHS-boot_frm_pxe_1.html
Comment 6 Rejy M Cyriac 2013-03-28 05:34:23 EDT
(In reply to comment #5)
> Based on the recommendation, the documentation has been updated and is
> available at:
> http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Storage/
> 2.0/html/Installation_Guide/sect-Installation_Guide-Install_RHS-
> boot_frm_pxe_1.html

Looking at the beginning of the entry: 

"Check SELinux status. You must ensure to disable, if found to be enforced or permissive." 

it seems ambiguous, on which system SELinux has to be disabled, since the text before the entry talks about troubleshooting the PXE server.

I would prefer the entry to be specific as

"Check SELinux status on the Red Hat Storage server after installation. You must ensure to disable, if found to be enforced or permissive."

Moving back to "assigned".

Cheers!

rejy (rmc)
Comment 8 Gowrishankar Rajaiyan 2013-03-28 08:32:26 EDT
Verified.

Note You need to log in before you can comment on or make changes to this bug.