Bug 863072 - WEBADMIN: Setupnetwork doesn't recognize logical network with vlan id 0
WEBADMIN: Setupnetwork doesn't recognize logical network with vlan id 0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Alona Kaplan
Yaniv Kaul
network
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 07:49 EDT by Avi Tal
Modified: 2016-04-22 00:59 EDT (History)
12 users (show)

See Also:
Fixed In Version: SI21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:04:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avi Tal 2012-10-04 07:49:13 EDT
Description of problem:
Setupnetworks can't handle vlan id 0 because it is not recognized as vlan interface.

Vlan 0 is a useful id when user will like to treat the vlaned interface as un-tagged.
This is fully supported in RHEL and RHEVM 3.0 there for this bug is actually a regression from 3.0


Setupnetworks display vlan 0 network as a regular network without vlan
and cause few problems:
1. can't add multiple vlans over int/bond if one is vlan 0.
2. adding multiple vlans when one is vlan 0 via rest api (old api)
   will lead setupnetworks freezing when try to display this topology.


Steps to Reproduce:
1. create logical network with vlan 0
2. add to cluster
3. add to host via setupnetworks
  
Actual results:
open setupnetworks and see that the networks doesn't assign as vlaned network

Expected results:
should treat vlan 0 as regular vlan.

Additional info:
Comment 1 Alona Kaplan 2012-10-04 09:21:28 EDT
http://gerrit.ovirt.org/#/c/8358/
Comment 3 GenadiC 2012-10-16 10:06:12 EDT
The same problem occurs when performing upgrade from Cluster 3.0 to Cluster 3.1 - After upgrade it's impossible to drag any network on interface with existing network with vlan 0
When performing verify to this bz, the above scenario should be tested as well
Comment 4 Martin Pavlik 2012-10-18 04:56:40 EDT
on SI21 setup networks works as expected

Note You need to log in before you can comment on or make changes to this bug.