Bug 863104 - PyQt FTBFS against sip-4.14+
PyQt FTBFS against sip-4.14+
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PyQt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 08:57 EDT by Rex Dieter
Modified: 2012-11-10 18:55 EST (History)
4 users (show)

See Also:
Fixed In Version: PyQt-3.18.1-14.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-10 18:55:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2012-10-04 08:57:10 EDT
PyQt currently FTBFS against sip-4.14+.  see
https://koji.fedoraproject.org/koji/buildinfo?buildID=357632

Get a bazillion of these (not an error, but still a concern):
sip: Deprecation warning: sip/qt/qsizegrip.sip:23: %ExportedDoc is deprecated, use %Extract instead


tail end of build.log includes:
sip/qt/qimage.sip: In function 'const char** PyQt_qt_ListToArray(PyObject*)':
sip/qt/qimage.sip:535:13: error: 'ANY' was not declared in this scope
sip/qt/qimage.sip:535:18: error: expected primary-expression before ')' token
sip/qt/qobject.sip: At global scope:
sip/qt/qobject.sip:1256:1: warning: missing initializer for member '_heaptypeobject::as_number' [-Wmissing-field-initializers]
sip/qt/qobject.sip:1256:1: warning: missing initializer for member '_heaptypeobject::as_mapping' [-Wmissing-field-initializers]
sip/qt/qobject.sip:1256:1: warning: missing initializer for member '_heaptypeobject::as_sequence' [-Wmissing-field-initializers]
sip/qt/qobject.sip:1256:1: warning: missing initializer for member '_heaptypeobject::as_buffer' [-Wmissing-field-initializers]
sip/qt/qobject.sip:1256:1: warning: missing initializer for member '_heaptypeobject::ht_name' [-Wmissing-field-initializers]
sip/qt/qobject.sip:1256:1: warning: missing initializer for member '_heaptypeobject::ht_slots' [-Wmissing-field-initializers]
qt/sipqtcmodule.cpp:12334:1: warning: narrowing conversion of 'PYQT_VERSION' from 'unsigned int' to 'int' inside { } is ill-formed in C++11 [-Wnarrowing]
Comment 1 Rex Dieter 2012-10-04 09:04:26 EDT
while we're at it, (again) consider if it may be worth retiring PyQt (and PyKDE).  Affected packages would include:

$ repoquery --whatrequires PyQt
PyKDE-0:3.16.6-10.fc18.x86_64
PyQt-devel-0:3.18.1-12.fc18.i686
PyQt-devel-0:3.18.1-12.fc18.x86_64
PyQt-examples-0:3.18.1-12.fc18.x86_64
ScientificPython-qt-0:2.8-16.fc18.x86_64
kodos-0:2.4.9-12.fc18.noarch
kphotobymail-0:0.4.1-11.fc18.noarch
luma-0:2.4-11.fc18.noarch
pipviewer-0:0.3.9-12.fc18.noarch
smart-gui-0:1.3.1-68.fc17.x86_64
Comment 2 Kevin Kofler 2012-11-10 18:28:10 EST
This FTBFS was caused by this sip commit: http://www.riverbankcomputing.co.uk/hg/sip/rev/40aeb5a8f98e

Fix: adding -DANY=void to the compiler flags.

Other legacy Qt3-based bindings (such as PyKDE 3) may need the same fix, if they still use the same old macro.

Note You need to log in before you can comment on or make changes to this bug.