Bug 863155 - SELinux prevents swat/net/winbindd from writing to /var/nmbd/unexpected socket
SELinux prevents swat/net/winbindd from writing to /var/nmbd/unexpected socket
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.9
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
: Regression
Depends On:
Blocks: 5.9BaseOSQEissues
  Show dependency treegraph
 
Reported: 2012-10-04 10:34 EDT by Ales Zelinka
Modified: 2013-01-07 22:34 EST (History)
4 users (show)

See Also:
Fixed In Version: selinux-policy-2.4.6-338.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:34:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Zelinka 2012-10-04 10:34:56 EDT
time->Mon Oct  1 15:12:46 2012
type=SYSCALL msg=audit(1349118766.731:98): arch=c000003e syscall=42 success=no exit=-111 a0=9 a1=2b2b43fffce8 a2=6e a3=0 items=0 ppid=20814 pid=20942 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="swat" exe="/usr/sbin/swat" subj=root:system_r:swat_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1349118766.731:98): avc:  denied  { write } for  pid=20942 comm="swat" name="unexpected" dev=dm-0 ino=48169025 scontext=root:system_r:swat_t:s0-s0:c0.c1023 tcontext=root:object_r:samba_var_t:s0 tclass=sock_file

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.4.6-336.el5.noarch
samba3x-3.6.6-0.126.el5
Comment 4 Ales Zelinka 2012-10-04 10:46:49 EDT
and winbind:

time->Mon Oct  1 15:25:52 2012
type=SYSCALL msg=audit(1349119552.260:112): arch=40000003 syscall=102 success=yes exit=0 a0=3 a1=bfff1830 a2=df3ff4 a3=a749910 items=0 ppid=19851 pid=19854 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="winbindd" exe="/usr/sbin/winbindd" subj=root:system_r:winbind_t:s0 key=(null)
type=AVC msg=audit(1349119552.260:112): avc:  denied  { connectto } for  pid=19854 comm="winbindd" path="/var/nmbd/unexpected" scontext=root:system_r:winbind_t:s0 tcontext=root:system_r:nmbd_t:s0 tclass=unix_stream_socket
type=AVC msg=audit(1349119552.260:112): avc:  denied  { write } for  pid=19854 comm="winbindd" name="unexpected" dev=dm-0 ino=326184 scontext=root:system_r:winbind_t:s0 tcontext=root:object_r:samba_var_t:s0 tclass=sock_file
Comment 6 Miroslav Grepl 2012-10-11 08:13:03 EDT
Fixed in selinux-policy-2.4.6-338.el5
Comment 10 errata-xmlrpc 2013-01-07 22:34:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0060.html

Note You need to log in before you can comment on or make changes to this bug.