This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 863180 - [RFE] add --lab-controller to beaker-import script
[RFE] add --lab-controller to beaker-import script
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.10.0
: ---
Assigned To: Dan Callaghan
Amit Saha
DistroManagement
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 11:40 EDT by Bill Peck
Modified: 2015-07-26 18:14 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 01:44:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2012-10-04 11:40:11 EDT
Description of problem:

There is no reason now why we can't run the beaker-import script from a different host.  This is handy if we are mirroring from a NAS or some other server than the lab controller.

Version-Release number of selected component (if applicable):
0.9.3
Comment 1 Bill Peck 2012-10-04 13:25:31 EDT
http://gerrit.beaker-project.org/#/c/1408/
Comment 2 Amit Saha 2012-11-08 23:56:02 EST
Verified.


# beaker-import --lab-controller=http://localhost:8001 http://download.bne.redhat.com/nightly/RHEL-7.0-20121101.n.0/compose/Server/x86_64/os/
Importing: http://download.bne.redhat.com/nightly/RHEL-7.0-20121101.n.0/compose/Server/x86_64/os/
'failed to add RedHatEnterpriseLinux-7.0 to beaker: [Errno 111] Connection refused'


The above lab controller was non-existent. So looks like it obeys the option.
Comment 3 Raymond Mancy 2012-11-22 01:44:19 EST
This has now been released

Note You need to log in before you can comment on or make changes to this bug.