Bug 863225 - Reclaim path to resize leads to LVM autopart by default.
Reclaim path to resize leads to LVM autopart by default.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:665b8383b24c2ad88893b3b31db...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 14:21 EDT by Jesse Keating
Modified: 2013-01-09 22:36 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 21:50:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (324.46 KB, text/plain)
2012-10-04 14:21 EDT, Jesse Keating
no flags Details
File: product (6 bytes, text/plain)
2012-10-04 14:21 EDT, Jesse Keating
no flags Details
File: type (9 bytes, text/plain)
2012-10-04 14:21 EDT, Jesse Keating
no flags Details
File: storage.log (152.81 KB, text/plain)
2012-10-04 14:21 EDT, Jesse Keating
no flags Details
File: version (11 bytes, text/plain)
2012-10-04 14:21 EDT, Jesse Keating
no flags Details
File: environ (818 bytes, text/plain)
2012-10-04 14:21 EDT, Jesse Keating
no flags Details
File: anaconda.log (15.99 KB, text/plain)
2012-10-04 14:21 EDT, Jesse Keating
no flags Details
File: syslog (59.50 KB, text/plain)
2012-10-04 14:21 EDT, Jesse Keating
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-04 14:21 EDT, Jesse Keating
no flags Details
File: packaging.log (2.36 KB, text/plain)
2012-10-04 14:21 EDT, Jesse Keating
no flags Details
File: cmdline_file (215 bytes, text/plain)
2012-10-04 14:21 EDT, Jesse Keating
no flags Details
File: release (24 bytes, text/plain)
2012-10-04 14:21 EDT, Jesse Keating
no flags Details
File: program.log (59.81 KB, text/plain)
2012-10-04 14:21 EDT, Jesse Keating
no flags Details
anaconda-tb-dyujGr (18.12) (797.27 KB, text/plain)
2012-10-06 16:03 EDT, Steve Tyler
no flags Details

  None (edit)
Description Jesse Keating 2012-10-04 14:21:18 EDT
Description of problem:
This is after the first time through custom where I removed existing partitions and then clicked to autocreate.

I got an error about there not being enough space, so I went into custom again and tried to delete the existing partitions, only to get this traceback.


Version-Release number of selected component:
anaconda-18.11

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.11 exception report
:Traceback (most recent call first):
:  File "/tmp/updates/pyanaconda/storage/__init__.py", line 3252, in device_size
:    return get_pv_space(self.size, len(self.disks), **size_func_kwargs)
:  File "/tmp/updates/pyanaconda/storage/__init__.py", line 1850, in setContainerMembers
:    device_space = factory.device_size
:  File "/tmp/updates/pyanaconda/ui/gui/spokes/custom.py", line 1411, in _destroy_device
:    parents = self.__storage.setContainerMembers(container, factory)
:  File "/tmp/updates/pyanaconda/ui/gui/spokes/custom.py", line 1462, in on_remove_clicked
:    self._destroy_device(device)
:NameError: global name 'size_func_kwargs' is not defined
Comment 1 Jesse Keating 2012-10-04 14:21:20 EDT
Created attachment 621762 [details]
File: anaconda-tb
Comment 2 Jesse Keating 2012-10-04 14:21:22 EDT
Created attachment 621763 [details]
File: product
Comment 3 Jesse Keating 2012-10-04 14:21:24 EDT
Created attachment 621764 [details]
File: type
Comment 4 Jesse Keating 2012-10-04 14:21:25 EDT
Created attachment 621765 [details]
File: storage.log
Comment 5 Jesse Keating 2012-10-04 14:21:27 EDT
Created attachment 621766 [details]
File: version
Comment 6 Jesse Keating 2012-10-04 14:21:28 EDT
Created attachment 621767 [details]
File: environ
Comment 7 Jesse Keating 2012-10-04 14:21:30 EDT
Created attachment 621768 [details]
File: anaconda.log
Comment 8 Jesse Keating 2012-10-04 14:21:31 EDT
Created attachment 621769 [details]
File: syslog
Comment 9 Jesse Keating 2012-10-04 14:21:33 EDT
Created attachment 621770 [details]
File: hashmarkername
Comment 10 Jesse Keating 2012-10-04 14:21:34 EDT
Created attachment 621771 [details]
File: packaging.log
Comment 11 Jesse Keating 2012-10-04 14:21:36 EDT
Created attachment 621772 [details]
File: cmdline_file
Comment 12 Jesse Keating 2012-10-04 14:21:38 EDT
Created attachment 621773 [details]
File: release
Comment 13 Jesse Keating 2012-10-04 14:21:40 EDT
Created attachment 621774 [details]
File: program.log
Comment 14 Fedora Update System 2012-10-05 16:55:03 EDT
anaconda-18.13-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.13-1.fc18
Comment 15 Steve Tyler 2012-10-06 10:12:06 EDT
With anaconda-18.13-1.fc18, this bug was a duplicate ...
Comment 16 Steve Tyler 2012-10-06 16:03:45 EDT
Created attachment 622796 [details]
anaconda-tb-dyujGr (18.12)

NameError: global name 'size_func_kwargs' is not defined

This is with 18.12. I couldn't reproduce this with 18.13, so it may be that I downloaded 18.13, but didn't install it. Sorry about the confusion.

$ qemu-kvm -m 2048 -hda f18-test-3.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC2/Fedora-18-Beta-TC2-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on
Comment 17 Fedora Update System 2012-10-08 20:21:10 EDT
anaconda-18.14-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.14-1.fc18
Comment 18 Fedora Update System 2012-10-09 13:20:43 EDT
Package anaconda-18.14-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.14-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15707/anaconda-18.14-1.fc18
then log in and leave karma (feedback).
Comment 19 Adam Williamson 2012-11-22 21:50:55 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.