Bug 863264 - Help live migration converge when guest dirties pages too fast
Help live migration converge when guest dirties pages too fast
Status: CLOSED DUPLICATE of bug 867453
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
: FutureFeature
Depends On:
Blocks: 867453
  Show dependency treegraph
Reported: 2012-10-04 17:37 EDT by Karen Noel
Modified: 2015-09-22 09 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 867453 (view as bug list)
Last Closed: 2013-06-19 10:14:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Karen Noel 2012-10-04 17:37:02 EDT
This new feature will help live migration converge when the guest is dirtying pages too fast for the network throughput.

The performance team is using a script like this:

# cat migrated_cgroup.sh
# Enter guest name $1
# Try for 120 seconds with 10 percent of 1-cpu
echo 10000 > /cgroup/cpu/libvirt/qemu/$1/vcpu0/cpu.cfs_quota_us
echo 10000 > /cgroup/cpu/libvirt/qemu/$1/vcpu1/cpu.cfs_quota_us
sleep 120
# Try for 2 minutes with 1% of the cpu of 1-cpu
echo 1000 > /cgroup/cpu/libvirt/qemu/$1/vcpu0/cpu.cfs_quota_us
echo 1000 > /cgroup/cpu/libvirt/qemu/$1/vcpu1/cpu.cfs_quota_us
sleep 120
# Increase the period to then reduce to .1% of 1-cpu.
echo 1000000 > /cgroup/cpu/libvirt/qemu/$1/vcpu0/cpu.cfs_period_us
echo 1000000 > /cgroup/cpu/libvirt/qemu/$1/vcpu1/cpu.cfs_period_us
echo 1000 > /cgroup/cpu/libvirt/qemu/$1/vcpu0/cpu.cfs_quota_us
echo 1000 > /cgroup/cpu/libvirt/qemu/$1/vcpu1/cpu.cfs_quota_us

This logic should be refined and put into libvirt so it's automatic for the customer.
Comment 1 Eric Blake 2012-10-04 19:28:03 EDT
Additionally, libvirt should be using the qemu 1.2 feature of XBZRLE migration, if it can determine that both sides of the migration support it (which also means that XBZRLE needs to be backported into RHEL qemu).
Comment 2 Jiri Denemark 2012-10-08 08:15:58 EDT
XBZRLE support is requested by bug 842857
Comment 5 Jiri Denemark 2013-03-27 12:02:05 EDT
Libvirt already supports changing CPU scheduling parameters and I thing doing so automagically goes beyond libvirt's competency. It should be higher-level management (vdsm probably) doing that.
Comment 6 Itamar Heim 2013-06-19 10:14:20 EDT

*** This bug has been marked as a duplicate of bug 867453 ***

Note You need to log in before you can comment on or make changes to this bug.