Bug 863276 - f18b anaconda white screen instead of the main hub, it currently only happens on a single kvm guest
f18b anaconda white screen instead of the main hub, it currently only happen...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 18:48 EDT by Reartes Guillermo
Modified: 2012-10-10 22:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 22:48:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the white (or gray/grey) screen (33.59 KB, image/png)
2012-10-04 18:48 EDT, Reartes Guillermo
no flags Details
anaconda.log (1.27 KB, text/plain)
2012-10-04 18:49 EDT, Reartes Guillermo
no flags Details
program log (20.23 KB, text/plain)
2012-10-04 18:49 EDT, Reartes Guillermo
no flags Details
storage log (50.42 KB, text/plain)
2012-10-04 18:49 EDT, Reartes Guillermo
no flags Details
syslog (63.13 KB, text/plain)
2012-10-04 18:50 EDT, Reartes Guillermo
no flags Details
X.log (white screen after accepting fate) (17.75 KB, text/plain)
2012-10-05 10:46 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-04 18:48:15 EDT
Created attachment 621834 [details]
the white (or gray/grey) screen

Description of problem:

In am not able to reach anaconda's main hub, but only on a certain KVM GUEST.
I don't know why yet.

I tried:

* Increased memory from 1GB to 2GB
* Changed display from SPICE/QLX to VNC/CIRRUS

No efect.

Issue:  After 'i accept my fate', the screen remains empty (white/gray) as shown in the screenshot.

Update: I tried with F18b TC2 and it is the same.



Version-Release number of selected component (if applicable):
F18b TC1 & TC2

How reproducible:
always (with this kvm guest)

Steps to Reproduce:
1. boot
2. accept 'fate'
  
Actual results:
no main hub, installing is not possible

Expected results:
main hub

Additional Info:

The anaconda is not hung, the mouse works, alt+tab works (nothing to switch to), alt+vt works. It just does not display the main hub. :-(
Comment 1 Reartes Guillermo 2012-10-04 18:49:06 EDT
Created attachment 621835 [details]
anaconda.log
Comment 2 Reartes Guillermo 2012-10-04 18:49:27 EDT
Created attachment 621836 [details]
program log
Comment 3 Reartes Guillermo 2012-10-04 18:49:57 EDT
Created attachment 621837 [details]
storage log
Comment 4 Reartes Guillermo 2012-10-04 18:50:18 EDT
Created attachment 621838 [details]
syslog
Comment 5 Daniel Vrátil 2012-10-04 19:28:32 EDT
I can confirm this issue on F18 Beta TC1 Live KDE running on Thinkpad T410 (with nvidia graphics card)

anaconda-18.12-1.fc18
Comment 6 Chris Lumens 2012-10-05 10:38:50 EDT
Can we see /tmp/X.log as well?
Comment 7 Reartes Guillermo 2012-10-05 10:46:20 EDT
Created attachment 622243 [details]
X.log (white screen after accepting fate)
Comment 8 Chris Lumens 2012-10-05 11:14:04 EDT
My guess is we're hung in anaconda waiting for something - who knows what.  Unless we can reliably reproduce this here to step through, or you feel like doing the debugging, though, I'm not optimistic.
Comment 9 Reartes Guillermo 2012-10-05 11:45:03 EDT
I tried install gdb (to generate a core dump from anaconda) to the booted dvd but it was not possible because yum fails with a 'no module named yumain'.

So no gdb and no core dump.
Also there is no ifconfig on the dvd... not sure if a bug-report is needed for those or is it by design.
Comment 10 Daniel Vrátil 2012-10-08 10:42:20 EDT
I can reliably reproduce the issue with F18 Beta TC2 KDE in VirtualBox.

Is there any way I can provide debug information? Is a GDB stacktrace of the Python process enough, or is there any Python version of GDB?
Comment 11 Chris Lumens 2012-10-08 10:49:48 EDT
There's something called pdb for python, but the way I would approach debugging with that is to insert the following lines somewhere where the hub is getting set up:

import pdb
pdb.set_trace()

Then switch over to tty1 when you know those lines get hit and start stepping through the code.  Really, it would be easiest if I could reproduce this.
Comment 12 Reartes Guillermo 2012-10-09 21:34:51 EDT
I was able to reach the main hub with F18b TC3 and the same guest.
Just in case i tested with both SPICE/QLX and VNC/Cirrus. 

So, either it was fixed or it does not happen anymore with F18b TC3.
Comment 13 Chris Lumens 2012-10-10 08:48:07 EDT
Unless everyone's now seeing success, I still think this is intermittent enough to be left open.
Comment 14 Daniel Vrátil 2012-10-10 09:19:38 EDT
I found out that my problem is caused by an oxygen-gtk3 issue in the KDE spin and is unrelated to the original problem reported here.

Note You need to log in before you can comment on or make changes to this bug.