This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 863286 - Rebase nspr to 4.9.2 or 4.9.3
Rebase nspr to 4.9.2 or 4.9.3
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nspr (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Elio Maldonado Batiz
Aleš Mareček
: Rebase
: 833149 883780 (view as bug list)
Depends On:
Blocks: 837089 863285
  Show dependency treegraph
 
Reported: 2012-10-04 20:19 EDT by Elio Maldonado Batiz
Modified: 2015-05-06 07:15 EDT (History)
6 users (show)

See Also:
Fixed In Version: nspr-4.9.2-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:44:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Elio Maldonado Batiz 2012-10-04 20:19:57 EDT
Description of problem: Rebasing nspr to 4.9.3 is required to be rebase nss-util and nss to 3.14 which have been requested to add support for TLS 1.1.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 Kai Engert (:kaie) 2012-10-12 11:14:24 EDT
Built nspr-4.9.2-1.el6

(NSPR 4.9.2 shall be sufficient for NSS 3.14, NSPR 4.9.3 is not yet ready.)
Comment 5 Karel Srot 2012-10-15 09:02:29 EDT
Hi,
could you please summarize changes since last build and point out some items that deserve to be tested (except TLS1.1?
Thank you in advance.
Comment 6 Bob Relyea 2012-10-16 15:34:02 EDT
The only new change to NSPR are two new functions:

PR_SetCurrentThreadName() and PR_GetCurrentThreadName().

I believe the normal regression tests should suffice, I'll have Elio look up any tests for the two new NSPR functions (he'll be in Wednesday).

bob
Comment 7 Elio Maldonado Batiz 2012-10-18 14:59:57 EDT
There are now tests for this functions that I can see.

/*
** Set the name of the current thread, which will be visible in a debugger
** and accessible via a call to PR_GetThreadName().
*/
NSPR_API(PRStatus) PR_SetThreadName(const char *name);	changed to	
NSPR_API(PRStatus) PR_SetCurrentThreadName(const char *name);

This is a renaming to make it's purpose clear.
 		 
/*
** Return the name of "thread", if set. Otherwise return NULL.
*/
NSPR_API(const char *) PR_GetThreadName(); changed to	
NSPR_API(const char *) PR_GetThreadName(const PRThread *thread);

In this one it was implicitly the current thread only and now the caller
specifies the thread whose name is desired. This was requested to help in debugging. 

I don't see any unit tests added specifically for this. If we write some simple test is best to add it to nspr's own test suite and contribute it upstream.
Comment 8 Karel Srot 2012-10-29 12:39:01 EDT
*** Bug 833149 has been marked as a duplicate of this bug. ***
Comment 9 Aleš Mareček 2012-10-30 10:54:39 EDT
Hi Elio,
how does it look like with those tests for functions mentioned in comment#7? Could I help somehow?
Regards!
Comment 10 Elio Maldonado Batiz 2012-10-30 13:25:59 EDT
(In reply to comment #9)
> Hi Elio,
> how does it look like with those tests for functions mentioned in comment#7?
> Could I help somehow?
> Regards!

Yes, I could use a second pair of eyes to get them correctly sooner and it will help you undertand you understand nspr a bit better.
Comment 11 Aleš Mareček 2012-12-06 09:20:31 EST
*** Bug 883780 has been marked as a duplicate of this bug. ***
Comment 12 Bob Relyea 2013-01-22 12:53:36 EST
Hmm, the bug is in the errata, I don't see any unanswered QA questions, moving to ON_QA.
Comment 15 errata-xmlrpc 2013-02-21 05:44:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0445.html

Note You need to log in before you can comment on or make changes to this bug.