Bug 863296 - [abrt] nemo-1.0.2-1.fc18: _gdk_x11_display_error_event: Process /usr/bin/nemo was killed by signal 5 (SIGTRAP)
[abrt] nemo-1.0.2-1.fc18: _gdk_x11_display_error_event: Process /usr/bin/nemo...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: nemo (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
abrt_hash:d9fd1798815eba91354eb85190c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 21:59 EDT by Ricardo Silva
Modified: 2013-06-09 11:03 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-19 04:36:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.86 KB, text/plain)
2012-10-04 21:59 EDT, Ricardo Silva
no flags Details
File: environ (1.54 KB, text/plain)
2012-10-04 21:59 EDT, Ricardo Silva
no flags Details
File: backtrace (36.16 KB, text/plain)
2012-10-04 21:59 EDT, Ricardo Silva
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-04 21:59 EDT, Ricardo Silva
no flags Details
File: cgroup (130 bytes, text/plain)
2012-10-04 21:59 EDT, Ricardo Silva
no flags Details
File: maps (48.78 KB, text/plain)
2012-10-04 21:59 EDT, Ricardo Silva
no flags Details
File: dso_list (9.74 KB, text/plain)
2012-10-04 21:59 EDT, Ricardo Silva
no flags Details
File: var_log_messages (862 bytes, text/plain)
2012-10-04 21:59 EDT, Ricardo Silva
no flags Details
File: open_fds (937 bytes, text/plain)
2012-10-04 21:59 EDT, Ricardo Silva
no flags Details
Screenshot of dconf-editor on my configuration (62.20 KB, image/png)
2013-06-09 11:03 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description Ricardo Silva 2012-10-04 21:59:05 EDT
Version-Release number of selected component:
nemo-1.0.2-1.fc18

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        nemo -n
crash_function: _gdk_x11_display_error_event
kernel:         3.6.0-2.fc18.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #2 _gdk_x11_display_error_event at gdkdisplay-x11.c:2417
: #6 handle_error at xcb_io.c:212
: #7 handle_response at xcb_io.c:324
: #8 _XEventsQueued at xcb_io.c:363
: #9 XPending at Pending.c:55
: #10 gdk_check_xpending at gdkeventsource.c:266
: #11 gdk_event_source_prepare at gdkeventsource.c:280
: #12 g_main_context_prepare at gmain.c:2986
: #14 g_main_context_iteration at gmain.c:3351
: #15 g_application_run at gapplication.c:1620
Comment 1 Ricardo Silva 2012-10-04 21:59:07 EDT
Created attachment 621893 [details]
File: core_backtrace
Comment 2 Ricardo Silva 2012-10-04 21:59:09 EDT
Created attachment 621894 [details]
File: environ
Comment 3 Ricardo Silva 2012-10-04 21:59:12 EDT
Created attachment 621895 [details]
File: backtrace
Comment 4 Ricardo Silva 2012-10-04 21:59:14 EDT
Created attachment 621896 [details]
File: limits
Comment 5 Ricardo Silva 2012-10-04 21:59:16 EDT
Created attachment 621897 [details]
File: cgroup
Comment 6 Ricardo Silva 2012-10-04 21:59:19 EDT
Created attachment 621898 [details]
File: maps
Comment 7 Ricardo Silva 2012-10-04 21:59:21 EDT
Created attachment 621899 [details]
File: dso_list
Comment 8 Ricardo Silva 2012-10-04 21:59:23 EDT
Created attachment 621900 [details]
File: var_log_messages
Comment 9 Ricardo Silva 2012-10-04 21:59:25 EDT
Created attachment 621901 [details]
File: open_fds
Comment 10 Lynn Dixon 2013-01-23 00:59:11 EST
Tried to launch nemo from  the menus.

backtrace_rating: 4
Package: nemo-1.1.2-1.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 11 brice 2013-02-05 17:43:18 EST
just boot the system and got the crash.and the desktop doesn't load. in fact i have gnome, mate and cinnamon installed
and don't  understand why nemo crash when i boot a gnome session


backtrace_rating: 4
Package: nemo-1.1.2-1.fc18
Architecture: i686
OS Release: Fedora release 18 (Spherical Cow)
Comment 12 Kevin.B.W.lee 2013-02-07 20:45:13 EST
I've just logout and login.

backtrace_rating: 4
Package: nemo-1.1.2-1.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 13 Lynn Dixon 2013-03-06 19:29:57 EST
I am still getting this bug....CONSTANTLY.  Was there a reason it was closed as "works for me"?  Is there someway I can fix it?
Comment 14 Felix Schwarz 2013-03-07 02:51:43 EST
I think the problem went away for me when I disabled nautilus' autostart: run 'gnome-session-properties' and untick the checkbox for 'files' (there should be two but one says 'nemo' in the description so uncheck the other one).
Comment 15 D. Charles Pyle 2013-04-04 14:29:19 EDT
Same just happened to me.  Tried to report it but abrt refused to add the information to this because it was closed.
Comment 16 D. Charles Pyle 2013-04-04 14:31:18 EDT
The workaround in comment 14 will not work for me. I already had nautilus's autostart in gnome-session-properties unchecked.
Comment 17 D. Charles Pyle 2013-04-14 10:24:37 EDT
Still seeing the problem, this time not on logon but while in the middle of working on something.  Abrt refuses to let me submit the latest error data because this bug report was closed.
Comment 18 Gabriele Svelto 2013-04-24 01:43:30 EDT
I'm also still seeing this problem, mostly during startup where it crashes once every few times. I have double-checked that nautilus is not being started automatically nor is running when this happens so the problem must be elsewhere.
Comment 19 Johannes Fenzl 2013-05-05 10:24:47 EDT
I had the same problem. Nemo crashed everytime I changed my monitors (which changed the display resolution). The following setting worked for me:

(1) Start dconf-editor
(2) Set in org.gnome.desktop.background "draw-background" to "false"
Comment 20 D. Charles Pyle 2013-06-09 11:03:00 EDT
Created attachment 758821 [details]
Screenshot of dconf-editor on my configuration

The workaround mentioned in comment 19 won't work for me.  That option of "draw-background" isn't even there in my configuration.  That said, I have noticed that these crashes have not been happening very frequently of late.

I am now at the following version:

$ rpm -qa nemo
nemo-1.8.2-3.fc19.x86_64

Note You need to log in before you can comment on or make changes to this bug.