Bug 863306 - bkr.labcontroller.main daemonization and signal handling needs some massage
bkr.labcontroller.main daemonization and signal handling needs some massage
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.11
: ---
Assigned To: beaker-dev-list
ImplementationQuality
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 23:41 EDT by Raymond Mancy
Modified: 2015-05-03 22:05 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 20:57:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raymond Mancy 2012-10-04 23:41:13 EDT
beaker proxy (bkr.labcontroller.main) currently does a couple of odd things.

The `daemon_shutdown()` SIGTERM handler can never work because the 'login' variable is not accessible, and it handles 'KeyboardInterrupt' regardless of whether it is daemonized or not.

Perhaps we should look at reworking it to be closer to how beakerd works.
Comment 2 Dan Callaghan 2013-07-18 20:57:11 EDT
I believe at this point all four LC daemons have been tidied up to be consistent with each other, and with beakerd, and to run correctly both foregrounded and daemonized.

Note You need to log in before you can comment on or make changes to this bug.