This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 863346 - Plug-in data directories are not preserved during agent auto-update
Plug-in data directories are not preserved during agent auto-update
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
4.5
x86_64 Linux
unspecified Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 03:50 EDT by Andreas Veithen
Modified: 2017-03-18 17:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-18 17:13:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Veithen 2012-10-05 03:50:36 EDT
According to the Javadoc of PluginContext#getDataDirectory(), the directory returned by that method (which is $RHQ_AGENT_HOME/data/<plug-in name>) is a "Directory where plugins can store persisted data that survives agent restarts".

The obvious expectation is that this remains true even during an auto-update of the agent. In fact, since the auto-update only changes the version of the plug-in container, but not the version of the plug-ins (at least not for custom plug-ins), there is no reason why the plug-in data directories would be reset.

However, the observed behavior during an auto-update (from 3.0.0 to 4.5.1) is that the data directories are moved together with the old agent installation (to $RHQ_AGENT_HOME-OLD) and not restored to the new agent installation.
Comment 1 Heiko W. Rupp 2013-07-01 06:29:02 EDT
Andreas,

after the agent has auto-updated, it will get new(er) plugin versions from the server which also has updated and is (at least for stock RHQ plugins) thus also having newer plugins.
Do I understand you correctly that your custom plugin is staying the same and thus expects to e.g. fetch temporary data from the data/ directory, which has gone?

Note You need to log in before you can comment on or make changes to this bug.