This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 863370 - F18/QA test : English lines in ibus for Japanese
F18/QA test : English lines in ibus for Japanese
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
18
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 05:19 EDT by Kiyoto Hashida
Modified: 2013-03-13 01:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-19 06:07:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kiyoto Hashida 2012-10-05 05:19:24 EDT
Description of problem:
In the F18 QA test, Japanese version has got English lines
similar to German ans Spanish reports, but more.


Version-Release number of selected component (if applicable):
Fedora18/20120924-test_days-i386_no2.iso

How reproducible:
Every time when you enter command "ibus-setup" in the terminal.


Steps to Reproduce:
1.Enter "ibus-setup" as root.
2.Observe the first screen.
3.Proceed to the next screen.
4.Open all the tabs.
  
Actual results:
1. The first screen has got "The IBus daemon is not running.Do you wish to start it?"
2. Next screen shows all the lines in English.
3. In the third screen, the "input method" tab has "Customize active input methods" in English.


Expected results:
Those English entries should be translated into Japanese.
1. IBus デーモンは稼働していません。開始しますか?
2. I can't display it now. (shows up only on the first attempt)
3. アクティブな入力メソッドをカスタマイズする


Additional info:
Other languages would have the same problem.
But I am not sure if they are all the same.
Comment 1 Noriko Mizumoto 2012-10-09 01:51:26 EDT
Hi Package maintainer,

This package has been translated 100% via Transifex [1]. However the above mentioned strings don't exist in the file provided. It is suspected that POT file has not been updated with latest strings.
Could you kindly look at this?

[1]https://fedora.transifex.com/projects/p/ibus/
Comment 2 fujiwara 2012-10-11 05:03:04 EDT
Sorry, I forgot to update the repo since I'm not fun of this English update in this time.
Now transifex is the latest.
Comment 3 Noriko Mizumoto 2012-10-11 05:52:59 EDT
Fujiwara-san

Thanks.
Becuase the software translation deadline was over, so let me ask you.
If we update translation, can you still pull and include them into Fedora 18 release still?
Comment 4 fujiwara 2012-10-11 22:11:44 EDT
(In reply to comment #3)
> Becuase the software translation deadline was over, so let me ask you.
> If we update translation, can you still pull and include them into Fedora 18
> release still?

I'm thinking this update after f18 release because the untranslations are not so critical.
1 and 2 are happened only when the ibus-daemon is not running. If you run im-chooser at first instead of ibus-setup, the message won't be shown.

And I think you use non-gnome-shell desktop (maybe metacity + gnome-panel or non-GNOME desktops) and the initial login locale might be en_US.UTF-8.
If you use gnome-shell desktop, ibus-setup is not recommended but 'gnome-control-center region' is the default configuration.

I guess your 2 means:
"IBus daemon coundn't be started in %d seconds"

I will replace s/coundn't be/could not be/ tomorrow and also change the msgid to plural.

3 has been happened since f15 and I'd move 3 to bug 862185.

If you update the translations, I'd like to update ibus post f18 GA.
Comment 5 fujiwara 2012-12-19 06:07:19 EST
Now I think 1 and 2 are fixed.
and 3 is to use ibus-xkb likes bug 862185.
If you update ibus-xkb, I will merge the translations with ibus ones.
So I'd like to close this as rawhide.

BTW, if a project is configured to use outsourced Fedora project in transifex, it seems maintainer cannot update the translation in transifex. However translations could be updated by both upstream directly and transifex so probably I have no way to update translations with Fedora project in transifex.
Comment 6 fujiwara 2012-12-20 03:40:23 EST
(In reply to comment #5)
> BTW, if a project is configured to use outsourced Fedora project in
> transifex, it seems maintainer cannot update the translation in transifex.
> However translations could be updated by both upstream directly and
> transifex so probably I have no way to update translations with Fedora
> project in transifex.

This is fixed after talked locally.

Note You need to log in before you can comment on or make changes to this bug.