Bug 8634 - termcap xterm entries don't match terminfo (or a real xterm)
termcap xterm entries don't match terminfo (or a real xterm)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: termcap (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-19 16:43 EST by Hans de Goede
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-01 15:50:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for /etc/termcap which fixes the described problems (1.47 KB, patch)
2000-01-19 16:44 EST, Hans de Goede
no flags Details | Diff

  None (edit)
Description Hans de Goede 2000-01-19 16:43:14 EST
The termcap entry for xterm has a few problems:
-it is based on xterm-r6, whereas terminfo is based on xterm-xf86-v40
-it doesn't contain an entry for end (@7)
-the delete entry for the xterm-xf86-vxx entries is wrong

The attaced patch fixes these 3 problems.
Comment 1 Hans de Goede 2000-01-19 16:44:59 EST
Created attachment 69 [details]
Patch for /etc/termcap which fixes the described problems
Comment 2 Hans de Goede 2000-01-19 16:46:59 EST
This patch is different from the one I send you (bero) by email, since it now
uses xterm-xf86-v40 for xterm just like the new ncurses rpm's do.
Comment 3 Hans de Goede 2000-01-30 09:09:59 EST
Please change termcap-fixes.gz to the patch attached to this bug report, it is
identical except that it maps xterm to xterm-xf86-v40 instead of xterm-xf86-v33,
this matches the changes made to terminfo in the ncurses-5.0-6 release.
Comment 4 Preston Brown 2000-02-01 15:50:59 EST
fixed in termcap-10.2.7-4 and later.

Note You need to log in before you can comment on or make changes to this bug.