Bug 863412 - Installed boot loader does not offer recovery options
Installed boot loader does not offer recovery options
Status: CLOSED DUPLICATE of bug 859632
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 08:22 EDT by Florian Weimer
Modified: 2012-10-05 10:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 10:38:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot screen after pressing "e" (176.37 KB, image/png)
2012-10-05 08:22 EDT, Florian Weimer
no flags Details

  None (edit)
Description Florian Weimer 2012-10-05 08:22:43 EDT
Created attachment 622133 [details]
Boot screen after pressing "e"

I assume that the F18 installer installs grub2.  If this is incorrect, please reassign.

The boot menu does not offer any recovery options.  Pressing "e" as instructed just blanks out the rectangle in the middle of the screen, so this option isn't very helpful either.
Comment 1 Mads Kiilerich 2012-10-05 08:34:22 EDT
What have you installed?
Comment 2 Florian Weimer 2012-10-05 08:38:15 EDT
I installed Fedora-18-Alpha-x86_64-Live-Desktop.iso in a VM.  I will attempt another install and see if the results are different.
Comment 3 Mads Kiilerich 2012-10-05 08:43:09 EDT
That problem should have been fixed.

Please update the system and run grub2-install and grub2-mkconfig and verify that it solves the problem.
Comment 4 Florian Weimer 2012-10-05 09:18:47 EDT
(In reply to comment #3)
> Please update the system and run grub2-install and grub2-mkconfig and verify
> that it solves the problem.

grub2-install and grub2-mkconfig do not change when they aren't invoked with certain arguments.  I ran "grub2-install /dev/vda", but I don't know the correct way to invoke grub2-mkconfig.

Shouldn't this happen automatically during package update?
Comment 5 Mads Kiilerich 2012-10-05 09:21:27 EDT
(In reply to comment #4)
> I ran "grub2-install /dev/vda", but I don't know the
> correct way to invoke grub2-mkconfig.

See /usr/share/doc/grub2-tools-2.0/README.Fedora

> Shouldn't this happen automatically during package update?

Not the way it is designed. (But the new EFI support will make it more confusing.)
Comment 6 Florian Weimer 2012-10-05 10:29:30 EDT
Okay, this fixed it, thanks.  The window is still narrow, but seems to work.
Comment 7 Mads Kiilerich 2012-10-05 10:38:50 EDT
(Please include exact version information when reporting issues. And if possible try to verify if problems have been fixed before reporting.)

*** This bug has been marked as a duplicate of bug 859632 ***

Note You need to log in before you can comment on or make changes to this bug.