This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 863451 - AttributeError: 'DeviceFormat' object has no attribute 'peStart'
AttributeError: 'DeviceFormat' object has no attribute 'peStart'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:e672fabe79671da5ae35e46f4ab...
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-10-05 09:49 EDT by Reartes Guillermo
Modified: 2012-10-24 19:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 19:14:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (414.76 KB, text/plain)
2012-10-05 09:50 EDT, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-10-05 09:50 EDT, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-10-05 09:50 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-05 09:50 EDT, Reartes Guillermo
no flags Details
File: storage.log (217.16 KB, text/plain)
2012-10-05 09:50 EDT, Reartes Guillermo
no flags Details
File: version (11 bytes, text/plain)
2012-10-05 09:50 EDT, Reartes Guillermo
no flags Details
File: environ (761 bytes, text/plain)
2012-10-05 09:50 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (30.84 KB, text/plain)
2012-10-05 09:50 EDT, Reartes Guillermo
no flags Details
File: syslog (68.08 KB, text/plain)
2012-10-05 09:50 EDT, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-05 09:50 EDT, Reartes Guillermo
no flags Details
File: packaging.log (2.32 KB, text/plain)
2012-10-05 09:50 EDT, Reartes Guillermo
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-05 09:50 EDT, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-10-05 09:50 EDT, Reartes Guillermo
no flags Details
File: program.log (60.02 KB, text/plain)
2012-10-05 09:50 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-05 09:49:46 EDT
Description of problem:
* deleted all existing partions

* used the feature to create a partition template (or whatever such feature is called -some  people call it "automatic partitioning prima or bis"-) 

tried to remove devices in the UNKNOWN tree....

 


Version-Release number of selected component:
anaconda-18.12

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.12 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 2273, in size
:    size += max(0, self.align(pv.size - pv.format.peStart))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 680, in _do_refresh
:    selector = page.addDevice(u.format.name, Size(spec="%f MB" % u.size), None, self.on_selector_clicked)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1507, in on_remove_clicked
:    self._do_refresh()
:AttributeError: 'DeviceFormat' object has no attribute 'peStart'
Comment 1 Reartes Guillermo 2012-10-05 09:50:01 EDT
Created attachment 622221 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2012-10-05 09:50:04 EDT
Created attachment 622222 [details]
File: product
Comment 3 Reartes Guillermo 2012-10-05 09:50:06 EDT
Created attachment 622223 [details]
File: type
Comment 4 Reartes Guillermo 2012-10-05 09:50:09 EDT
Created attachment 622224 [details]
File: ifcfg.log
Comment 5 Reartes Guillermo 2012-10-05 09:50:18 EDT
Created attachment 622225 [details]
File: storage.log
Comment 6 Reartes Guillermo 2012-10-05 09:50:20 EDT
Created attachment 622226 [details]
File: version
Comment 7 Reartes Guillermo 2012-10-05 09:50:23 EDT
Created attachment 622227 [details]
File: environ
Comment 8 Reartes Guillermo 2012-10-05 09:50:28 EDT
Created attachment 622228 [details]
File: anaconda.log
Comment 9 Reartes Guillermo 2012-10-05 09:50:32 EDT
Created attachment 622229 [details]
File: syslog
Comment 10 Reartes Guillermo 2012-10-05 09:50:34 EDT
Created attachment 622230 [details]
File: hashmarkername
Comment 11 Reartes Guillermo 2012-10-05 09:50:37 EDT
Created attachment 622231 [details]
File: packaging.log
Comment 12 Reartes Guillermo 2012-10-05 09:50:39 EDT
Created attachment 622232 [details]
File: cmdline_file
Comment 13 Reartes Guillermo 2012-10-05 09:50:44 EDT
Created attachment 622233 [details]
File: release
Comment 14 Reartes Guillermo 2012-10-05 09:50:48 EDT
Created attachment 622234 [details]
File: program.log
Comment 15 Reartes Guillermo 2012-10-05 10:01:21 EDT
the issue happens when deleting the last entry in the 'UNKNOWN' (when the whole tree ?should? disappear)
Comment 16 Reartes Guillermo 2012-10-05 10:03:29 EDT
By just starting to delete the entries in 'UNKNOWN' tree, it happens after
deleting the last entry.

Note: the elements are not really deleted, but just assume they are and continue one by one until the last one.
Comment 17 Reartes Guillermo 2012-10-05 10:04:40 EDT
I propose it as a blocker because maybe that is the disc in which one might want to install fedora (and thus, it cannot generate the requiered free space)
Comment 18 Adam Williamson 2012-10-10 14:19:06 EDT
Discussed at 2012-10-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-10/f18beta-blocker-review-3.2012-10-10-16.05.log.txt .

As we understand it, this bug can be described as follows:

It affects the custom partitioning mode. The design of custom partitioning is that existing partitions are grouped by the OS installation they appear to be a part of. Partitions that cannot be associated with an existing OS installation are grouped together into an 'UNKNOWN' group. This crash is triggered by deleting the last partition in the 'UNKNOWN' group.

Assuming that description is accurate, we accept this bug as a blocker per Beta criterion "The installer's custom partitioning mode must be capable of the following: Creating, destroying and assigning mount points to partitions of any specified size using most commonly-used filesystem types" . This decision can be re-visited if the description above turns out to be incorrect. We will test to verify the bug is as described.
Comment 19 Adam Williamson 2012-10-17 14:49:01 EDT
Discussed at 2012-10-17 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-17/f18beta-blocker-review-4.2012-10-17-16.00.log.txt . Anaconda team, can you please look into this? It doesn't appear to have received any attention.
Comment 20 Adam Williamson 2012-10-24 14:50:31 EDT
This still doesn't seem to have received any attention.

Reartes, can you reproduce this with 18.19 (TC6)? It'd be useful to know if it's still a problem.
Comment 21 Reartes Guillermo 2012-10-24 16:05:39 EDT
I tried with several guests (F18b TC6) and i was unable to reproduce it.
I managed to delete all unknown partitions (and the known ones) without crashing.
Comment 22 Adam Williamson 2012-10-24 19:14:32 EDT
As no-one else has hit this, I think possibly our best course is to close it for now; if anyone hits it, we can re-open it. Assuming it's been fixed by the many changes to the partitioning code between 18.12 and 18.19, setting CLOSED ERRATA.

Note You need to log in before you can comment on or make changes to this bug.