Bug 863488 - Windows guest ends up with black screen after resizing spice client window over 2560x1600 resolution
Windows guest ends up with black screen after resizing spice client window ov...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-qxl-driver-win (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Alon Levy
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 11:11 EDT by Marian Krcmarik
Modified: 2015-09-22 09 EDT (History)
7 users (show)

See Also:
Fixed In Version: qxl-win-unsigned-0.1-18
Doc Type: Bug Fix
Doc Text:
Previously, a Windows virtual machine using the arbitrary resolution change setting ended up with a black screen when spice-vdagent resized its resolution to higher than 2560x1600. Resizing back to lower resolution did not restore the virtual machine console. Now, the screen no longer goes black, and spice-vdagent allows resizing.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:48:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Krcmarik 2012-10-05 11:11:03 EDT
Description of problem:
Windows guest ends up with black screen once spice vdagent resizes resolution to higher than 2560x1600 When arbitary resolution change is in use. Resizing back to lower resolution does not restore Guest screen.
The same feature in Linux guest does work and It's posible to resize guest resolution until limitation of buffer size.

Version-Release number of selected component (if applicable):
vdagent-win-0.1-12
qxl-win-unsigned-0.1-15

How reproducible:
Always

Steps to Reproduce:
1. Set resolution on Windows guest to 2560x1600
2. Resize spice client window to higher resolution.
  
Actual results:
Black screen only is displayed on the guest.

Expected results:
It should allow resizing until buffer size and or rollback once It's over.

Additional info:
Comment 2 Alon Levy 2013-08-08 10:59:51 EDT
There is an *unsigned* driver that contains the fix, setting Fixed-in and moving to MODIFIED.
Comment 4 David Jaša 2013-10-04 09:12:27 EDT
The screen doesn't go black anymore, however when the resolution is changed by window resize and only one of the dimensions exceeds the limit, the resolution change fails completely. Would it be possible in such case to resize the guest to [min(desired_x, maximum_x), min(desired_y, maximum_y)] in 3.3 cycle?
Comment 5 David Jaša 2013-10-07 09:13:32 EDT
(In reply to David Jaša from comment #4)
> ...
> Would it be possible in such case to
> resize the guest to [min(desired_x, maximum_x), min(desired_y, maximum_y)]
> in 3.3 cycle?
Comment 7 David Jaša 2013-10-25 07:43:42 EDT
(In reply to David Jaša from comment #5)
> (In reply to David Jaša from comment #4)
> > ...
> > Would it be possible in such case to
> > resize the guest to [min(desired_x, maximum_x), min(desired_y, maximum_y)]
> > in 3.3 cycle?

I opened a separate bug for this: bug 1023423.
Comment 9 errata-xmlrpc 2014-01-21 09:48:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0053.html

Note You need to log in before you can comment on or make changes to this bug.