Bug 863510 - locale settings not properly set for root
locale settings not properly set for root
Status: CLOSED DUPLICATE of bug 858591
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 12:27 EDT by Jurgen Kramer
Modified: 2012-10-05 13:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 13:29:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2012-10-05 12:27:28 EDT
Description of problem:
When doing a su - to root warnings appear about locale settings

Version-Release number of selected component (if applicable):
Anaconda from Fedora18-Beta TC2

How reproducible:
always

Steps to Reproduce:
1. su -
2.
3.
  
Actual results:
See below

Expected results:
No problems with locale settings

Additional info:
Default install of Fedora 18 Beta TC2 only timezone changed to Europe/Amsterdam.
Freshly installed.


A few examples:

[kramer@localhost ~]$ su -
Password: 
-bash: warning: setlocale: LC_CTYPE: cannot change locale (en.UTF-8): No such file or directory
-bash: warning: setlocale: LC_COLLATE: cannot change locale (en.UTF-8): No such file or directory
-bash: warning: setlocale: LC_MESSAGES: cannot change locale (en.UTF-8): No such file or directory
-bash: warning: setlocale: LC_NUMERIC: cannot change locale (en.UTF-8): No such file or directory
-bash: warning: setlocale: LC_TIME: cannot change locale (en.UTF-8): No such file or directory
[root@localhost ~]# yum update
Failed to set locale, defaulting to C

[root@localhost ~]# scp lo-bash: warning: setlocale: LC_CTYPE: cannot change locale (en.UTF-8)
-bash: warning: setlocale: LC_CTYPE: cannot change locale (en.UTF-8)
[root@localhost ~]# scp local
Comment 1 Chris Lumens 2012-10-05 13:29:13 EDT

*** This bug has been marked as a duplicate of bug 858591 ***

Note You need to log in before you can comment on or make changes to this bug.