Bug 863513 - Review Request: compat-telepathy-farstream - Telepathy client library to handle Call channels
Review Request: compat-telepathy-farstream - Telepathy client library to hand...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 12:59 EDT by Rex Dieter
Modified: 2012-12-20 11:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:03:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bdpepple: fedora‑review+
tibbs: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2012-10-05 12:59:10 EDT
Spec URL: http://rdieter.fedorapeople.org/rpms/telepathy/compat-telepathy-farstream.spec
SRPM URL: http://rdieter.fedorapeople.org/rpms/telepathy/compat-telepathy-farstream-0.4.0-3.fc18.src.rpm
Description: Telepathy client library to handle Call channels
Fedora Account System Username: rdieter

This is a telepathy-farstream-0.4-based compatibility package, for clients not yet ported to telepathy-farstream-0.6 (and gstreamer-1.0) yet.  This is primarily for supporting telepathy-qt-farstream bindings (and ktp-call-ui).
Comment 1 Brian Pepple 2012-10-05 16:52:23 EDT
Package Revew:
[x]: Header files in -devel subpackage, if present.
[x]: Package does not contain any libtool archives (.la)
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package contains no bundled libraries.
[x]: Changelog in prescribed format.
[!]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
     Note: rm -rf %{buildroot} present but not required
[x]: Sources contain only permissible code or content.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Permissions on files are set properly.
[x]: Package complies to the Packaging Guidelines
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: License file installed when any subpackage combination is installed.
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named using only allowed ASCII characters.
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package do not use a name that already exist
[x]: Package obeys FHS, except libexecdir and /usr/target.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package installs properly.
[x]: Requires correct, justified where necessary.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file is legible and written in American English.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.

rpmlint produces the following warning that can be dealt with when you import the package.

+1 APPROVED
Comment 2 Brian Pepple 2012-10-05 16:53:02 EDT
sigh... forgot to add the rpmlint output:

Checking: compat-telepathy-farstream-0.4.0-3.fc19.src.rpm
          compat-telepathy-farstream-devel-0.4.0-3.fc19.x86_64.rpm
          compat-telepathy-farstream-debuginfo-0.4.0-3.fc19.x86_64.rpm
          compat-telepathy-farstream-0.4.0-3.fc19.x86_64.rpm
compat-telepathy-farstream.src: E: description-line-too-long C compat-telepathy-farstream is a Telepathy client library that uses Farstream to handle
compat-telepathy-farstream-devel.x86_64: E: description-line-too-long C The compat-telepathy-farstream-devel package contains libraries and header files for
compat-telepathy-farstream-devel.x86_64: W: no-documentation
compat-telepathy-farstream.x86_64: E: description-line-too-long C compat-telepathy-farstream is a Telepathy client library that uses Farstream to handle
4 packages and 0 specfiles checked; 3 errors, 1 warnings.
Comment 3 Rex Dieter 2012-10-05 17:37:48 EDT
Thanks!

New Package SCM Request
=======================
Package Name: compat-telepathy-farstream
Short Description: Telepathy client library to handle Call channels
Owners: rdieter
Branches: f18
InitialCC:
Comment 4 Jason Tibbitts 2012-10-08 12:41:02 EDT
Git done (by process-git-requests).
Comment 5 Fedora Update System 2012-10-09 19:38:20 EDT
compat-telepathy-farstream-0.4.0-3.fc18,telepathy-qt4-0.9.3-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/compat-telepathy-farstream-0.4.0-3.fc18,telepathy-qt4-0.9.3-3.fc18
Comment 6 Fedora Update System 2012-10-10 01:03:52 EDT
compat-telepathy-farstream-0.4.0-3.fc18, telepathy-qt4-0.9.3-3.fc18 has been pushed to the Fedora 18 testing repository.
Comment 7 Fedora Update System 2012-12-20 11:03:54 EST
compat-telepathy-farstream-0.4.0-3.fc18, telepathy-qt4-0.9.3-3.fc18 has been pushed to the Fedora 18 stable repository.

Note You need to log in before you can comment on or make changes to this bug.