Bug 86352 - CD-ROM icon does not disappear from Nautilus desktop when ejecting manually
CD-ROM icon does not disappear from Nautilus desktop when ejecting manually
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-20 03:30 EST by Pierre Sarrazin
Modified: 2015-01-07 19:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-27 12:17:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Sarrazin 2003-03-20 03:30:51 EST
Description of problem:
The CD-ROM icon does not disappear from the Nautilus desktop when
the CD-ROM is manually ejected from the drive.

Version-Release number of selected component (if applicable):
nautilus-2.0.6-6
autofs-3.1.7-33
gnome-vfs-1.0.5-6.ximian.1
gnome-vfs2-2.0.2-5

How reproducible:
Every time.

Steps to Reproduce:
1. Insert a data CD-ROM in the drive.
2. After about 10 seconds, the Nautilus desktop shows a CD-ROM icon.
3. Push the button on the drive to eject the CD-ROM manually.
4. Wait 5 seconds pour be sure that all moving parts have stopped.
5. The icon is still there; double-click on it: an empty Nautilus
   directory window appears.

Actual results:
An empty Nautilus directory window appears.

Expected results:
The CD-ROM icon should disappear from the Nautilus desktop as soon
as the drive starts ejecting the CD-ROM.

Additional info:

In the 'CD and DVD Preferences' window, the 'Mount CD
when inserted' checkbox is checked; the 'Start auto-run
program...' checkbox is NOT checked; the 'Open file
manager window...' checkbox is NOT checked.

My CD-ROM drive is a PlexWriter 8/4/32A from Plextor.

The mount directory is /mnt/cdrom.
The corresponding line in /etc/fstab is the following.
/dev/cdrom      /mnt/cdrom      iso9660 noauto,ro,user  0 0

My system ran RedHat 7.2 and I upgraded it to 8.0 recently.
I run GNOME 2.0, but there are still some GNOME 1.4 packages
in the system.
Comment 1 Alexander Larsson 2003-03-24 08:47:33 EST
Hmm?
Strange. On my machines pressing the eject button while the cd is mounted does
nothing. However, if you run e.g. "eject" from the command line the cd is
ejected and nautilus removes the cd icon.

What happens if you use the "eject" command to unmount/eject the cd?
Comment 2 Pierre Sarrazin 2003-03-24 10:57:17 EST
> On my machines pressing the eject button while the cd is mounted does
> nothing.

Strangely, step 3 above does not work this time: the CD icon is
present, and I press the drive's eject button, but now nothing
happens.

> However, if you run e.g. "eject" from the command line the cd is
> ejected and nautilus removes the cd icon.
> What happens if you use the "eject" command to unmount/eject the cd?

The CD is ejected and Nautilus removes the CD icon.

Well, the problem seems to have disappeared for now.

However, I wonder if Nautilus could not react to the drive's
eject button and eject the CD.
Comment 3 Alexander Larsson 2003-03-24 11:51:53 EST
Eject button handling is done entierly by the hardware. Not even the kernel can
affect it.

I wonder how you got into your original state though. It seems the cdrom was
somehow unmounted or at least unlocked, but nautilus didn't detect it. That
sounds like /etc/mtab wasn't changed. But that would be very strange....
Comment 4 Alexander Larsson 2003-08-27 12:17:15 EDT
Since this problem disappeared for you, and the way media icons has changed a
lot for the better recently i'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.