Bug 863552 - When upgrading to rawhide the repos fedora and updates are disabled by the upgrade but updates-testing is not causing problems
When upgrading to rawhide the repos fedora and updates are disabled by the up...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 15:00 EDT by Georgiy Treyvus
Modified: 2015-02-17 09:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 09:29:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Georgiy Treyvus 2012-10-05 15:00:15 EDT
Description of problem:

I enabled rawhide and did 'yum update'. Afterwards whenever I tried to do any operation with yum it was whining about it not being able to find some updates-testing repomd metalink file or something of the sort.

I though okay this is not a problem. Let me just check in /etc/yum.repos.d for any weirdness and disable updates-testing. After doing that yum was working normally again and the day was saved.

However I inspected all the .repo files and found some very interesting stuff. Surprisingly enough during the upgrade both the fedora and the updates repositories got disabled and I assume this was done for a good reason. The repository updates-testing however was not disabled and I had to disable that manually.

Like obviously this problem can't be completely solved because you the yum developers simply can't predict what third party repositories a user may enable. However the updates-testing repository isn't third party. It's a native part of Fedora and I saw the fedora-updates-testing.repo file in /etc/yum.repos.d from the very beginning. The upgrade to rawhide is intelligent enough to check and disable both the fedora and the updates repos if they are enabled. Bizarrely though it skips over updates-testing in spite of it being a native repository and not third party. This is inconsistent behaviour and must be fixed.

Fixing it make sense from a user perspective as it makes it that much easier for users to get their hands on the newest software. It also helps Fedora/Red Hat development in terms of there being more testers hunting out and reporting bugs like this one. 


Version-Release number of selected component (if applicable):
[root@PANTHER georgiy]# yum --version
3.4.3
  Installed: rpm-4.10.1-1.fc19.x86_64 at 2012-10-04 23:19
  Built    : Fedora Project at 2012-10-03 10:22
  Committed: Panu Matilainen <pmatilai@redhat.com> at 2012-10-03

  Installed: yum-3.4.3-43.fc19.noarch at 2012-10-04 23:22
  Built    : Fedora Project at 2012-09-07 19:55
  Committed: James Antill <james at fedoraproject.org> at 2012-09-07
[root@PANTHER georgiy]# 


How reproducible:
always
Comment 1 Fedora End Of Life 2013-04-03 12:57:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 2 Fedora End Of Life 2015-01-09 12:24:04 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 3 Fedora End Of Life 2015-02-17 09:29:24 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.