Bug 863572 - Need to Disable Back/Forward Buttons in Firstboot When We Show the Progress Bar
Need to Disable Back/Forward Buttons in Firstboot When We Show the Progress Bar
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adrian Likins
IDM QE LIST
:
: 874047 (view as bug list)
Depends On:
Blocks: 771481 840993 888457
  Show dependency treegraph
 
Reported: 2012-10-05 16:31 EDT by Matt Reid
Modified: 2013-04-29 10:22 EDT (History)
5 users (show)

See Also:
Fixed In Version: subscription-manager-1.1.16-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:57:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Buttons Enabled (93.84 KB, image/png)
2012-10-05 16:31 EDT, Matt Reid
no flags Details
crash report #1 (12.01 KB, text/plain)
2012-10-05 16:32 EDT, Matt Reid
no flags Details
crash report #2 (12.10 KB, text/plain)
2012-10-05 16:33 EDT, Matt Reid
no flags Details
Buttons Disabled (91.01 KB, image/png)
2012-12-18 13:34 EST, J.C. Molet
no flags Details

  None (edit)
Description Matt Reid 2012-10-05 16:31:10 EDT
Description of problem:
One thing I noticed while playing around with firstboot is that while in RHEL 5 we properly disable the navigation buttons when we show the progress bar for registering, we do not disable the buttons in RHEL 6. Not sure if firstboot behaves a bit differently between major versions or what, but being able to go backwards while its trying to register creates all sorts of fun and interesting possibilities that break firstboot.

I've managed to get AttributeError: 'NoneType' object has no attribute 'service_level' & TypeError: unsupported operand type(s) for +: 'NoneType' and 'int' (twice)

I'm 3/3 for crashing firstboot when messing with the buttons that should be disabled.

My favorite part is when you let it start registering, go back (which takes you back to choose a server), and then you move forward once or twice, if you pause on those screens, it'll jump you back to the progress bar without any input or even credentials entered, it just picks up where it was before.

Version:
subscription-manager-1.1.2-1.git.74.70cdd3c
Comment 1 Matt Reid 2012-10-05 16:31:47 EDT
Created attachment 622427 [details]
Buttons Enabled
Comment 2 Matt Reid 2012-10-05 16:32:46 EDT
Created attachment 622437 [details]
crash report #1
Comment 3 Matt Reid 2012-10-05 16:33:06 EDT
Created attachment 622438 [details]
crash report #2
Comment 4 Adrian Likins 2012-12-11 12:00:12 EST
*** Bug 874047 has been marked as a duplicate of this bug. ***
Comment 5 Adrian Likins 2012-12-17 10:02:45 EST
I think I see why this doesn't work in rhel6. 

We have code in place to grey out those buttons in the right places, but
on 6.4 we are toggling the wrong buttons. We are changing the buttons
that are displayed in the regular registergui gui. But in firstboot,
we hide those buttons and use the firstboot forward/backwards buttons 
instead. 

On 5.9, there is code that updates the references to those buttons, but
that code doesn't get hit in 6.4 (firstboot api changes). 

Just need to figure out how to get to the firstboot buttons, and
we can toggle them instead.
Comment 6 Adrian Likins 2012-12-17 16:20:42 EST
commit d771dc3d6fa8aba92eeb86a6c2fa1a54b3b02e8d
Author: Adrian Likins <alikins@redhat.com>
Date:   Mon Dec 17 12:49:08 2012 -0500

    863572: Make forward/back insensitive when registering
    
    When we register in firstboot, and we are showing the
    progress bar for each of the async steps, make the
    back/forward buttons in the firstboot gui insensitive.
Comment 8 J.C. Molet 2012-12-18 13:34:29 EST
Created attachment 665689 [details]
Buttons Disabled

Testing with:

subscription-manager-gui-1.1.16-1.el6.x86_64
python-rhsm-1.1.8-1.el6.x86_64
subscription-manager-firstboot-1.1.16-1.el6.x86_64
subscription-manager-1.1.16-1.el6.x86_64


I cannot replicate this bug when testing the above version.  The buttons are now grayed out and unclickable.

Marking VERIFIED.
Comment 10 errata-xmlrpc 2013-02-21 03:57:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.