Bug 863577 - Clarify instructions on the 'reclaim disk space' dialog
Clarify instructions on the 'reclaim disk space' dialog
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All All
unspecified Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 17:03 EDT by Adam Williamson
Modified: 2012-11-22 21:51 EST (History)
4 users (show)

See Also:
Fixed In Version: anaconda-18.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 21:51:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-10-05 17:03:40 EDT
The text on the 'reclaim disk space' dialog as of 18.12 reads:

"Some of the disks on your system have free space available in pre-existing filesystems. While it's risky and we recommend you back up your data first, you can recover that free disk space and make it available for this installation below:"

However, the dialog covers both shrink and delete operations. This text, to me, is really talking only about shrinking, and that left me rather confused about the capabilities of the dialog - for some seconds I was looking for some other place to simply _delete_ a partition, till I realized that was possible here too. I also think the text is slightly over-long.

mizmo says there are meant to be two versions of the text, one which shows up when both shrinking and deleting are possible, one when there's nothing that can be shrunk and only deleting is possible. So what we really need is one text to cover both shrinking and deleting possibilities, and one to cover only deleting possibilities.

I propose this:

"You can attempt to recover free disk space from filesystems on your computer, freeing up space for Fedora. This should not normally result in data loss, but it is risky and we recommend you back up your data before attempting this.

You can (also) remove existing filesystems you no longer need to free up space for Fedora. Removing a filesystem will permanently delete all the data it contains."

The first paragraph would only be displayed if shrinking is possible; the second would be displayed alone if only deleting is possible. The word 'also' would only appear in the second paragraph in the case where both paragraphs are displayed. The combination of the two is a bit longer than the existing text, but each one alone is shorter than the existing text.
Comment 1 Máirín Duffy 2012-10-08 15:51:01 EDT
Here's the text I would suggest:

"There is enough free space available to complete this installation in pre-existing filesystems. While it's risky and we recommend that you back up your data first, you can recover that free disk space and make it available for this installation below."

"You can (also) remove existing filesystems you no longer need to free up space for this installation. Removing a filesystem will permanently delete all of the data it contains."

I reworded some things for grammar, and also so we don't have the distribution name embedded in the text. (Generally we try to avoid this since RHEL among other distros use anaconda.)
Comment 2 Máirín Duffy 2012-10-08 15:59:48 EDT
If we have one message for both scenarios it should be:

"You don't have enough free space available for this installation."

"You can remove existing filesystems you no longer need to free up space for this installation. Removing a filesystem will permanently delete all of the data it contains."

"There is also free space available in pre-existing filesystems. While it's risky and we recommend that you back up your data first, you can recover that free disk space and make it available for this installation below."
Comment 3 Máirín Duffy 2012-10-08 16:02:29 EDT
There might be cases where the user doesn't have any shrinkable filesystems. Maybe on a mac that only has HFS+ partitions. In that case, the final paragraph in comment #2 should be dropped.
Comment 4 Adam Williamson 2012-10-10 00:16:32 EDT
Well I reckon the 'of' in 'all of the data' is unnecessary, but hey, strokes for folks =)

I specifically stated in my text that shrinking will not normally cause data loss for a reason. If we don't specifically state this, and you imagine yourself as someone who knows nothing about partitioning reading that sentence, it seems somewhat unclear to me. If this 'recover free disk space from pre-existing filesystems' option is risky and you should back up data first, why would you do it? I figured that explicitly stating that when all goes well it preserves your existing data was useful information as to why you would ever choose that option. But if you think it's not needed, I don't mind.
Comment 5 Adam Williamson 2012-10-10 00:19:54 EDT
Chris - I note the patch for this puts the paragraphs the other way around (presumably because you don't have to deal with the 'also' issue then). I don't really mind that, but do note that I originally drafted it that way, and Mo specifically wanted to change the order so that the paragraph about resizing came first, and the paragraph about deleting came second - she particularly wanted that order, it wasn't just a random choice which way around to put them.
Comment 6 Fedora Update System 2012-10-10 21:05:42 EDT
anaconda-18.15-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.15-1.fc18
Comment 7 Fedora Update System 2012-10-10 22:59:21 EDT
Package anaconda-18.15-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.15-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15903/anaconda-18.15-1.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-10-11 21:07:27 EDT
anaconda-18.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.16-1.fc18
Comment 9 Adam Williamson 2012-10-12 17:46:51 EDT
Confirming fixed in 18.16. The text is now taking up quite a bit of space, though. Perhaps the first line - 'You don't have enough space for this installation', or something similar - doesn't need to be its own paragraph and could be merged in with the second paragraph (the one about deleting partitions) to save space.
Comment 10 Fedora Update System 2012-10-16 23:10:31 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.17-1.fc18
Comment 11 Fedora Update System 2012-10-17 13:31:58 EDT
Package anaconda-18.17-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.17-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16295/anaconda-18.17-1.fc18
then log in and leave karma (feedback).
Comment 12 Adam Williamson 2012-10-17 18:54:20 EDT
back to VERIFIED. i should really file a bug with Luke that bodhi shouldn't change bugs from VERIFIED to ON_QA...
Comment 13 Fedora Update System 2012-10-17 22:39:16 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 14 Fedora Update System 2012-10-18 11:31:45 EDT
Package anaconda-18.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16402/anaconda-18.18-1.fc18
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2012-10-19 21:35:07 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 16 Adam Williamson 2012-11-22 21:51:36 EST
Fixed since 18.19.

Note You need to log in before you can comment on or make changes to this bug.