Bug 863584 - Trying to create bridge interface results in: Could not define interface: internal error could not get interface XML description: XSLT transformation failed - runtime error: file /usr/share/netcf/xml/initscripts-get.xsl line 196 element node
Trying to create bridge interface results in: Could not define interface: int...
Status: CLOSED DUPLICATE of bug 848722
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: netcf (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Laine Stump
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 18:28 EDT by Orion Poplawski
Modified: 2012-10-08 11:18 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 11:18:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2012-10-05 18:28:44 EDT
Description of problem:

Using virt-manager on Fedora 17, connecting via ssh to libvirtd on EL6.  Trying to create a new bridge network, copying the existing eth0 interface, but I get:

Error creating interface: 'Could not define interface: internal error could not get interface XML description: XSLT transformation failed - runtime error: file /usr/share/netcf/xml/initscripts-get.xsl line 196 element node
'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 96, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/createinterface.py", line 1135, in do_install
    self.interface.install(meter, create=activate)
  File "/usr/lib/python2.7/site-packages/virtinst/Interface.py", line 242, in install
    raise RuntimeError(_("Could not define interface: %s" % str(e)))
RuntimeError: Could not define interface: internal error could not get interface XML description: XSLT transformation failed - runtime error: file /usr/share/netcf/xml/initscripts-get.xsl line 196 element node

In /var/log/libvirtd.log on the server:

2012-10-05 22:24:11.943+0000: 2098: error : interfaceDefineXML:425 : internal error could not get interface XML description: XSLT transformation failed - runtime error: file /usr/share/netcf/xml/initscripts-get.xsl line 196 element node

Line 196:
        <xsl:if test="ip/@prefix">
196:          <node label="NETMASK" value="{ipcalc:netmask(ip/@prefix)}"/>
        </xsl:if>

Version-Release number of selected component (if applicable):
server:
libvirt-0.9.10-21.el6_3.4.x86_64

client:
virt-manager-0.9.4-1.fc17.noarch
libvirt-0.9.11.5-3.fc17.i686

/etc/sysconfig/network-scripts/ifcfg-eth0:
DEVICE=eth0
ONBOOT=yes
HWADDR=00:22:19:1D:0C:A4
TYPE=Ethernet
BOOTPROTO=static
IPADDR=4.28.99.164
NETMASK=255.255.255.224
DEFROUTE=yes
GATEWAY=4.28.99.161
GATEWAYDEV=eth0

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:22:19:1d:0c:a4 brd ff:ff:ff:ff:ff:ff
    inet 4.28.99.164/27 brd 4.28.99.191 scope global eth0
    inet6 fe80::222:19ff:fe1d:ca4/64 scope link 
       valid_lft forever preferred_lft forever
Comment 2 Laine Stump 2012-10-08 11:18:19 EDT
This is a problem in netcf (which libvirt is calling). Bug 848722 has details of the fix.

*** This bug has been marked as a duplicate of bug 848722 ***

Note You need to log in before you can comment on or make changes to this bug.