Bug 863589 - New VMs are created with SPICE enabled without querying for SPICE support in qemu-kvm
New VMs are created with SPICE enabled without querying for SPICE support in ...
Status: CLOSED DEFERRED
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 19:00 EDT by Elias Probst
Modified: 2016-03-23 18:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-23 18:53:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elias Probst 2012-10-05 19:00:31 EDT
Description of problem:
When creating a new VM through virt-manager, SPICE support is enabled even when qemu-kvm is built without SPICE support.

Version-Release number of selected component (if applicable):
libvirt-0.9.13
virt-manager-0.9.4
virtinst-0.600.3
qemu-kvm-1.1.1

Steps to Reproduce:
1. Build qemu-kvm without SPICE support
2. Create new VM
3. try to boot it initially
  
Actual results:
Initial boot of VM fails due to missing SPICE support

Expected results:
The VM is created with VNC instead, maybe the user notified about this change.


Additional information:
log from #virt:

[00:49:55] <eliasp> Cardoe: which component is responsible for this?
[00:50:09] <jlogan1> eliasp: I also noticed SPICE (kvm-spice) on Ubuntu does not have rbd support
[00:50:13] <Cardoe> I'd say its really libvirt's issue since it doesn't have in QemuCaps the knowledge of SPICE support.
[00:50:32] <eliasp> Cardoe: ok
[00:50:43] <Cardoe> jlogan1: Might be another thing we need to probe for.
[00:51:08] <Cardoe> eliasp: Dan and Eric can yell at me for saying the wrong thing later.
[00:51:43] <eliasp> haha, let's see ;)
[00:52:30] <eblake> I heard that :)
[00:53:06] <eblake> you're probably right that QemuCaps should add a capability for level of spice support, since we've proven that in the wild there are different defaults
[00:53:32] <eblake> any time a blind assumption gives awkward results, adding another QemuCaps makes it easier to make for useful error messages instead
Comment 1 Cole Robinson 2016-03-23 18:53:38 EDT
Sorry this never received a response. The root issue is that there's no way that spice support is communicated up from qemu through libvirt to virt-manager, so virt-manager doesn't know not to default to spice.

That said virt-manager has a global option to change from spice->vnc (in the preferences dialog), in these cases I just recommend using that.

Note You need to log in before you can comment on or make changes to this bug.