Bug 863605 - [abrt] dnf-0.2.12 - RuntimeException: load_yum_repo() failed.
[abrt] dnf-0.2.12 - RuntimeException: load_yum_repo() failed.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
abrt_hash:534b05d5e61d21508270661b4ef...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 23:19 EDT by Abhay
Modified: 2014-09-30 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-21 09:34:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (736 bytes, text/plain)
2012-10-05 23:19 EDT, Abhay
no flags Details

  None (edit)
Description Abhay 2012-10-05 23:19:46 EDT
Version-Release number of selected component:
dnf-0.2.12-2.git832ecd1.fc18

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        /usr/bin/python /usr/bin/dnf makecache
kernel:         3.6.0-0.rc7.git0.1.fc18.x86_64

backtrace:
:__init__.py:235:_add_repo_to_hawkey:RuntimeException: load_yum_repo() failed.
:
:Traceback (most recent call last):
:  File "/usr/bin/dnf", line 35, in <module>
:    yummain.user_main(sys.argv[1:], exit_code=True)
:  File "/usr/lib/python2.7/site-packages/dnf/cli/yummain.py", line 316, in user_main
:    errcode = main(args)
:  File "/usr/lib/python2.7/site-packages/dnf/cli/yummain.py", line 140, in main
:    result, resultmsgs = base.doCommands()
:  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 481, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/lib/python2.7/site-packages/dnf/cli/yumcommands.py", line 972, in doCommand
:    sack = base.sack # triggers metadata sync
:  File "/usr/lib/python2.7/site-packages/dnf/yum/__init__.py", line 252, in sack
:    self._add_repo_to_hawkey(r.id)
:  File "/usr/lib/python2.7/site-packages/dnf/yum/__init__.py", line 235, in _add_repo_to_hawkey
:    self._sack.load_yum_repo(repo, build_cache=True, load_filelists=True)
:RuntimeException: load_yum_repo() failed.
:
:Local variables in innermost frame:
:repo: <_hawkey.Repo object at 0x7f0c4807d240>
:self: <dnf.cli.cli.YumBaseCli object at 0x201b3d0>
:name: 'fedora'
:yum_repo: <dnf.yum.yumRepo.YumRepository object at 0x2034e10>
Comment 1 Abhay 2012-10-05 23:19:50 EDT
Created attachment 622580 [details]
File: core_backtrace
Comment 2 Ales Kozumplik 2012-10-08 02:14:43 EDT
Hello,

can you please give some information about how this bug gets triggered? Is it 'dnf makecache' run as root manually, from the hourly cron job or as a normal user? Did you experiment with some settings or permissions on DNF's cache directory?

Thank you!
Comment 3 Abhay 2012-10-08 03:03:25 EDT
Hi Ales,

i did nothing manually with a normal user account or with the root credentials. May be the crash is triggered by the system's cron job.

Thanks!
Comment 4 Ales Kozumplik 2012-10-08 03:32:17 EDT
Looking at the IO error handling code in hawkey there is currently little chance of debugging this directly. The steps I'll take into a future version to find out more are:

- improve the logging code for repo loading
- add abrt configuration file so hawkey.log is attached automatically to the abrt bugzillas.

Then we'll wait for someone to hit this again.
Comment 5 Ales Kozumplik 2012-10-08 06:20:47 EDT
(In reply to comment #4)
> - improve the logging code for repo loading

Hawkey commit 93c0f3a / hawkey-0.2.12
Comment 6 Ales Kozumplik 2012-10-08 08:10:13 EDT
Discovered related bug 864014 while working on the ABRT side of things.
Comment 7 Ales Kozumplik 2012-10-08 10:46:44 EDT
(In reply to comment #4)
> - add abrt configuration file so hawkey.log is attached automatically to the
> abrt bugzillas.

Taken care of by dnf commit ba9dc87 / dnf-0.2.14
Comment 8 Ales Kozumplik 2012-12-12 03:16:20 EST
Hi Abhay, are you still seeing this?
Comment 9 Abhay 2012-12-12 06:27:48 EST
(In reply to comment #8)
> Hi Abhay, are you still seeing this?

Hi Ales, i don't see this bug anymore.
Comment 10 Ales Kozumplik 2013-01-21 09:34:30 EST
I am closing this as WORKSFORME, as I am unable to reproduce this. Please reopen if you hit this again.

Note You need to log in before you can comment on or make changes to this bug.