Bug 863609 - KeyboardInterrupt
KeyboardInterrupt
Status: CLOSED DUPLICATE of bug 862828
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Sivák
Fedora Extras Quality Assurance
abrt_hash:d5a4aa118e3dcc9a0ee330fe01c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 00:08 EDT by Steve Tyler
Modified: 2012-10-17 08:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 08:56:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: environ (123 bytes, text/plain)
2012-10-06 00:08 EDT, Steve Tyler
no flags Details
File: type (9 bytes, text/plain)
2012-10-06 00:08 EDT, Steve Tyler
no flags Details
File: other involved packages (39 bytes, text/plain)
2012-10-06 00:08 EDT, Steve Tyler
no flags Details
File: product (8 bytes, text/plain)
2012-10-06 00:08 EDT, Steve Tyler
no flags Details
File: hashmarkername (9 bytes, text/plain)
2012-10-06 00:08 EDT, Steve Tyler
no flags Details
File: firstboot-tb (127.44 KB, text/plain)
2012-10-06 00:08 EDT, Steve Tyler
no flags Details
File: version (7 bytes, text/plain)
2012-10-06 00:08 EDT, Steve Tyler
no flags Details
File: release (33 bytes, text/plain)
2012-10-06 00:08 EDT, Steve Tyler
no flags Details
/var/log/messages (178.25 KB, text/plain)
2012-10-06 00:37 EDT, Steve Tyler
no flags Details

  None (edit)
Description Steve Tyler 2012-10-06 00:08:11 EDT
Version-Release number of selected component:
firstboot-18.4-1.fc18.x86_64

Additional info:
libreport version: 2.0.15
cmdline:        /usr/bin/python  /usr/sbin/firstboot
kernel:         3.6.0-1.fc18.x86_64

description:
:Traceback from firstboot:
:firstboot 18.4 exception report
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/firstboot/interface.py", line 105, in _nextClicked
:    self.advance()
:  File "/usr/lib/python2.7/site-packages/firstboot/interface.py", line 148, in advance
:    result = module.apply(self, self.testing)
:  File "/usr/share/firstboot/modules/date.py", line 49, in apply
:    rc = self.scd.firstboot_apply()
:  File "/usr/share/system-config-date/scdMainWindow.py", line 213, in firstboot_apply
:    return self.apply ()
:  File "/usr/share/system-config-date/scdMainWindow.py", line 154, in apply
:    time.sleep (2)
:KeyboardInterrupt
Comment 1 Steve Tyler 2012-10-06 00:08:13 EDT
Created attachment 622601 [details]
File: environ
Comment 2 Steve Tyler 2012-10-06 00:08:14 EDT
Created attachment 622602 [details]
File: type
Comment 3 Steve Tyler 2012-10-06 00:08:16 EDT
Created attachment 622603 [details]
File: other involved packages
Comment 4 Steve Tyler 2012-10-06 00:08:17 EDT
Created attachment 622604 [details]
File: product
Comment 5 Steve Tyler 2012-10-06 00:08:18 EDT
Created attachment 622605 [details]
File: hashmarkername
Comment 6 Steve Tyler 2012-10-06 00:08:20 EDT
Created attachment 622606 [details]
File: firstboot-tb
Comment 7 Steve Tyler 2012-10-06 00:08:21 EDT
Created attachment 622607 [details]
File: version
Comment 8 Steve Tyler 2012-10-06 00:08:23 EDT
Created attachment 622608 [details]
File: release
Comment 9 Steve Tyler 2012-10-06 00:26:00 EDT
This was the result of attempting to reproduce:
Bug 862828 - cancelling network time service kills firstboot 

Clicked "Cancel" while the "Starting NTP Service" dialog is displayed.

NB: I induced firstboot to run again by:
1. # systemctl enable firstboot-graphical.service
2. Editing /etc/sysconfig/firstboot:
RUN_FIRSTBOOT=YES
Comment 10 Steve Tyler 2012-10-06 00:37:31 EDT
Created attachment 622618 [details]
/var/log/messages

Oct  5 23:48:58 localhost abrtd: Directory 'libreport-2012-10-05-23:48:58-1080' creation detected
Oct  5 23:48:58 localhost firstboot[502]: Unhandled exception in firstboot occured.
Comment 11 Steve Tyler 2012-10-06 00:48:37 EDT
This was in an F18 VM installed with:
anaconda-18.13-1.fc18
Fedora-18-Beta-TC2-x86_64-Live-Desktop.iso

$ qemu-kvm -m 2048 -hda f18-test-3.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC2/Fedora-18-Beta-TC2-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on
Comment 12 Martin Sivák 2012-10-17 08:13:52 EDT
Did you press Ctrl-C? That is what KeyboardInterrupt exception really represents.
Comment 13 Steve Tyler 2012-10-17 08:53:14 EDT
(In reply to comment #12)
> Did you press Ctrl-C? That is what KeyboardInterrupt exception really
> represents.

No. The reproducer was:
Clicked "Cancel" while the "Starting NTP Service" dialog is displayed.
(Comment 9)

There is a snippet from /var/log/messages that might explain the KeyboardInterrupt here:
Bug 862828 - cancelling network time service kills firstboot 

This bug could be a dupe of Bug 862828.
Comment 14 Martin Sivák 2012-10-17 08:56:50 EDT
It probably is.

*** This bug has been marked as a duplicate of bug 862828 ***

Note You need to log in before you can comment on or make changes to this bug.