Bug 863634 - gxine segfaults in generic_JSGetProperty() on fedora 18 lxde spin.
Summary: gxine segfaults in generic_JSGetProperty() on fedora 18 lxde spin.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gxine
Version: 18
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Martin Sourada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-06 07:28 UTC by Masami Ichikawa
Modified: 2013-02-02 04:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-02 04:36:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Masami Ichikawa 2012-10-06 07:28:50 UTC
Description of problem:
gxine-0.5.907-6.fc18.x86_64 doesn't start. 

I am sorry I wanted to report it via abrt but it didn't cache SIGSEV[1]. so I paste gdb stack trace by myself.

[1]:https://bugzilla.redhat.com/show_bug.cgi?id=863632

Version-Release number of selected component (if applicable):
gxine-0.5.907-6.fc18.x86_64
gxine-mozplugin-0.5.907-6.fc18.x86_64

I use Fedora 18 Beta TC2 to run it.

How reproducible:
always

Steps to Reproduce:
run gxine from console or start menu.
  
Actual results:
I have got this stack trace.
[masami@localhost ~]$ gdb /usr/bin/gxine
GNU gdb (GDB) Fedora (7.5.0.20120926-24.fc18)
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/gxine...Reading symbols from /usr/bin/gxine...(no debugging symbols found)...done.
(no debugging symbols found)...done.
Missing separate debuginfos, use: debuginfo-install gxine-0.5.907-6.fc18.x86_64
(gdb) r
Starting program: /usr/bin/gxine 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7ffff19d1700 (LWP 6923)]
[New Thread 0x7ffff19b0700 (LWP 6924)]
[New Thread 0x7ffff198f700 (LWP 6925)]

(process:6919): Gtk-WARNING **: Locale not supported by C library.
	Using the fallback 'C' locale.
[New Thread 0x7fffe3db5700 (LWP 6926)]
[New Thread 0x7fffe32f9700 (LWP 6927)]
[New Thread 0x7fffe12e2700 (LWP 6928)]
[New Thread 0x7fffdcae0700 (LWP 6929)]
[New Thread 0x7fffd7bdd700 (LWP 6930)]
[New Thread 0x7fffd6ff3700 (LWP 6931)]
[New Thread 0x7fffd6625700 (LWP 6932)]

Program received signal SIGSEGV, Segmentation fault.
0x000000000043250b in generic_JSGetProperty ()
(gdb) bt
#0  0x000000000043250b in generic_JSGetProperty ()
#1  0x00000030b90d0f30 in js::GetPropertyHelper(JSContext*, JS::Handle<JSObject*>, long, unsigned int, JS::Value*) ()
   from /usr/lib64/xulrunner-2/libmozjs.so
#2  0x00000030b90b4ec1 in js::Interpret(JSContext*, js::StackFrame*, js::InterpMode) ()
   from /usr/lib64/xulrunner-2/libmozjs.so
#3  0x00000030b90b92bd in js::RunScript(JSContext*, JSScript*, js::StackFrame*) () from /usr/lib64/xulrunner-2/libmozjs.so
#4  0x00000030b90b94f4 in js::ExecuteKernel(JSContext*, JSScript*, JSObject&, JS::Value const&, js::ExecuteType, js::StackFrame*, JS::Value*) () from /usr/lib64/xulrunner-2/libmozjs.so
#5  0x00000030b90b9a94 in js::Execute(JSContext*, JSScript*, JSObject&, JS::Value*) ()
   from /usr/lib64/xulrunner-2/libmozjs.so
#6  0x00000030b904151c in JS_EvaluateUCScriptForPrincipals () from /usr/lib64/xulrunner-2/libmozjs.so
#7  0x00000030b904161a in JS_EvaluateScriptForPrincipals () from /usr/lib64/xulrunner-2/libmozjs.so
#8  0x00000030b9041672 in JS_EvaluateScript () from /usr/lib64/xulrunner-2/libmozjs.so
#9  0x0000000000431fe3 in se_eval_ext ()
#10 0x0000000000414f6f in engine_exec_obj ()
#11 0x000000000043dc42 in button_js_cb ()
#12 0x00000030a880f910 in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#13 0x00000030a8820d08 in signal_emit_unlocked_R () from /lib64/libgobject-2.0.so.0
#14 0x00000030a8828c8d in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
#15 0x00000030a8828de2 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#16 0x00000030bbe89ee6 in gtk_widget_show () from /lib64/libgtk-x11-2.0.so.0
#17 0x00000030bbc86242 in gtk_box_forall () from /lib64/libgtk-x11-2.0.so.0
#18 0x00000030bbcc14c4 in gtk_container_show_all () from /lib64/libgtk-x11-2.0.so.0
#19 0x00000030bbc86242 in gtk_box_forall () from /lib64/libgtk-x11-2.0.so.0
#20 0x00000030bbcc14c4 in gtk_container_show_all () from /lib64/libgtk-x11-2.0.so.0
#21 0x00000030bbc86242 in gtk_box_forall () from /lib64/libgtk-x11-2.0.so.0
#22 0x00000030bbcc14c4 in gtk_container_show_all () from /lib64/libgtk-x11-2.0.so.0
#23 0x00000030bbc86242 in gtk_box_forall () from /lib64/libgtk-x11-2.0.so.0
#24 0x00000030bbcc14c4 in gtk_container_show_all () from /lib64/libgtk-x11-2.0.so.0
#25 0x0000000000425f9e in noskin_main_init ()
#26 0x0000000000413164 in main ()
(gdb) 

Expected results:
start gxine.

Additional info:

Comment 1 Christoph Wickert 2012-12-06 13:46:48 UTC
When you file a bug against one of the spins, please make sure to CC the spin owner. I was not aware of this.

Comment 2 M. Edward (Ed) Borasky 2013-01-22 20:17:12 UTC
I am seeing this in the released LXDE spin.

Comment 3 Christoph Wickert 2013-01-22 20:26:16 UTC
Can one of you please provide a backtrace with ABRT?

Comment 4 M. Edward (Ed) Borasky 2013-01-23 01:30:51 UTC
How do I get abrt to catch the bug? It seems to escape abrt detection on my system.

Comment 5 Masami Ichikawa 2013-01-23 13:51:12 UTC
I installed released LXDE spin and ran gxine, I couldn't reproduced it but I got following message.
[masami@localhost ~]$ gxine
gxine: symbol lookup error: gxine: undefined symbol: JS_NewCompartmentAndGlobalObject

I did yum update and ran gxine, then I got same error message.

These packages are installed.
gxine-0.5.907-6.fc18.x86_64
gxine-mozplugin-0.5.907-6.fc18.x86_64

Comment 6 Martin Sourada 2013-01-23 14:04:24 UTC
(In reply to comment #5)
> I installed released LXDE spin and ran gxine, I couldn't reproduced it but I
> got following message.
> [masami@localhost ~]$ gxine
> gxine: symbol lookup error: gxine: undefined symbol:
> JS_NewCompartmentAndGlobalObject
> 
I've been hit by this too, seems like it's related to
https://bugs.launchpad.net/ubuntu/+source/gxine/+bug/772835

As for the bug, I don't think it's spin related. It's probably caused by my not-so-good patch to fix build with new gecko's mozjs. I'm currently in the middle to switching to mozjs185 (provided by js[-devel]), which should have more stable API. I'll post a link as soon as I have the packages built in koji so you can test if it fixes the issues (my local build is working OK after the change).

Comment 7 Martin Sourada 2013-01-23 14:30:22 UTC
Please try this build. If it fixes the issue(s) for you I'll submit it as update.
http://koji.fedoraproject.org/koji/buildinfo?buildID=380233

Comment 8 Masami Ichikawa 2013-01-23 15:11:36 UTC
>Please try this build. If it fixes the issue(s) for you I'll submit it as update.
Thanks! It works fine for me. I didn't see any problems to run gxine from command line, start menu, and double click an ogg file.

Comment 9 Fedora Update System 2013-01-23 15:47:41 UTC
gxine-0.5.907-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gxine-0.5.907-7.fc18

Comment 10 Fedora Update System 2013-01-24 22:36:04 UTC
Package gxine-0.5.907-7.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gxine-0.5.907-7.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1435/gxine-0.5.907-7.fc18
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2013-02-02 04:36:52 UTC
gxine-0.5.907-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.