Bug 863652 - [abrt]: BUG: sleeping function called from invalid context at kernel/rwsem.c:20: TAINTED G D
[abrt]: BUG: sleeping function called from invalid context at kernel/rwsem.c:...
Status: CLOSED DUPLICATE of bug 863653
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:274791922beceefb7bee769a8ec...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 06:00 EDT by Patrick Bregman
Modified: 2012-11-12 16:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-12 16:00:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Bregman 2012-10-06 06:00:53 EDT
Description of problem:
I tried to start a FreeBSD VM in KVM with PCI passthrough set on an Asus USB3/SATA3 PCIe card. I forwarded all the PCIe bridges on that card and the USB3 and the SATA3 "card"/chip to the VM. The moment I started the VM, Fedora's virt-manager appeared to hang for a little while, after which I was dropped to a text console with the kernel panic.

The relevant part of lspci is:
01:00.0 PCI bridge: PLX Technology, Inc. PEX 8608 8-lane, 8-Port PCI Express Gen 2 (5.0 GT/s) Switch (rev ba)
02:01.0 PCI bridge: PLX Technology, Inc. PEX 8608 8-lane, 8-Port PCI Express Gen 2 (5.0 GT/s) Switch (rev ba)
02:05.0 PCI bridge: PLX Technology, Inc. PEX 8608 8-lane, 8-Port PCI Express Gen 2 (5.0 GT/s) Switch (rev ba)
02:07.0 PCI bridge: PLX Technology, Inc. PEX 8608 8-lane, 8-Port PCI Express Gen 2 (5.0 GT/s) Switch (rev ba)
02:09.0 PCI bridge: PLX Technology, Inc. PEX 8608 8-lane, 8-Port PCI Express Gen 2 (5.0 GT/s) Switch (rev ba)
03:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev ff)
04:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9120 SATA 6Gb/s Controller (rev ff)

The kernel threw some errors during bootup, before Fedora's boot splash appeared. These were all relating to ata7 and 8, which I presume are on the SATA chip. Those errors were:
[   12.742612] ata7: softreset failed (1st FIS failed)
[   12.743609] ata8: softreset failed (1st FIS failed)
[   12.748917] dmar: DRHD: handling fault status reg 2
[   12.749685] dmar: DMAR:[DMA Write] Request device [04:00.1] fault addr fffe0000 
DMAR:[fault reason 02] Present bit in context entry is clear
[   12.751850] dmar: DMAR:[DMA Write] Request device [04:00.1] fault addr fffc0000 
DMAR:[fault reason 02] Present bit in context entry is clear
[   13.047266] dmar: DRHD: handling fault status reg 2
[   13.048034] dmar: DMAR:[DMA Read] Request device [04:00.1] fault addr fffe0000 
DMAR:[fault reason 02] Present bit in context entry is clear
[   22.730671] ata7: softreset failed (1st FIS failed)
[   22.731652] ata8: softreset failed (1st FIS failed)
[   22.736939] dmar: DRHD: handling fault status reg 2
[   22.737707] dmar: DMAR:[DMA Write] Request device [04:00.1] fault addr fffe0000 
DMAR:[fault reason 02] Present bit in context entry is clear
[   22.739872] dmar: DMAR:[DMA Write] Request device [04:00.1] fault addr fffc0000 
DMAR:[fault reason 02] Present bit in context entry is clear
[   23.035350] dmar: DRHD: handling fault status reg 2
[   23.036117] dmar: DMAR:[DMA Read] Request device [04:00.1] fault addr fffe0000 
DMAR:[fault reason 02] Present bit in context entry is clear
[   57.686396] ata7: softreset failed (1st FIS failed)
[   57.687154] ata7: limiting SATA link speed to 1.5 Gbps
[   57.687384] ata8: softreset failed (1st FIS failed)
[   57.688139] ata8: limiting SATA link speed to 1.5 Gbps
[   57.692756] dmar: DRHD: handling fault status reg 2
[   57.693523] dmar: DMAR:[DMA Write] Request device [04:00.1] fault addr fffe0000 
DMAR:[fault reason 02] Present bit in context entry is clear
[   57.695690] dmar: DMAR:[DMA Write] Request device [04:00.1] fault addr fffc0000 
DMAR:[fault reason 02] Present bit in context entry is clear
[   57.991054] dmar: DRHD: handling fault status reg 2
[   57.991821] dmar: DMAR:[DMA Read] Request device [04:00.1] fault addr fffe0000 
DMAR:[fault reason 02] Present bit in context entry is clear
[   62.679942] ata7: softreset failed (1st FIS failed)
[   62.680700] ata7: reset failed, giving up
[   62.681965] ata8: softreset failed (1st FIS failed)
[   62.682736] ata8: reset failed, giving up

Additional info:
libreport version: 2.0.15
abrt_version:   2.0.14
cmdline:        BOOT_IMAGE=/vmlinuz-3.6.0-0.rc7.git1.4.fc18.x86_64 root=UUID=502ceada-dbc4-43dc-92cb-88f9196f1f4e ro rd.md=0 rd.lvm=0 rd.dm=0 rd.luks=0 rhgb quiet intel_iommu=on
kernel:         3.6.0-0.rc7.git1.4.fc18.x86_64

kernel_tainted_long:
:Proprietary module has not been loaded.
:Kernel has oopsed before

backtrace:
:BUG: sleeping function called from invalid context at kernel/rwsem.c:20
:in_atomic(): 0, irqs_disabled(): 1, pid: 681, name: libvirtd
:INFO: lockdep is turned off.
:irq event stamp: 561534
:hardirqs last  enabled at (561533): [<ffffffff81069e6b>] vprintk_emit+0x19b/0x5a0
:hardirqs last disabled at (561534): [<ffffffff816ded66>] error_sti+0x5/0x6
:softirqs last  enabled at (438754): [<ffffffff81071e57>] __do_softirq+0x167/0x3d0
:softirqs last disabled at (438737): [<ffffffff816e863c>] call_softirq+0x1c/0x30
:Pid: 681, comm: libvirtd Tainted: G      D      3.6.0-0.rc7.git1.4.fc18.x86_64 #1
:Call Trace:
: [<ffffffff810d40c0>] ? print_irqtrace_events+0xd0/0xe0
: [<ffffffff810a29ca>] __might_sleep+0x18a/0x240
: [<ffffffff816db836>] down_read+0x26/0x98
: [<ffffffff81081ff4>] exit_signals+0x24/0x130
: [<ffffffff8106e82d>] do_exit+0xbd/0xb20
: [<ffffffff8106b488>] ? kmsg_dump+0x1b8/0x240
: [<ffffffff8106b2f5>] ? kmsg_dump+0x25/0x240
: [<ffffffff816df7ae>] oops_end+0x9e/0xe0
: [<ffffffff816d0676>] no_context+0x258/0x283
: [<ffffffff81069e6b>] ? vprintk_emit+0x19b/0x5a0
: [<ffffffff816d086b>] __bad_area_nosemaphore+0x1ca/0x1e9
: [<ffffffff816d089d>] bad_area_nosemaphore+0x13/0x15
: [<ffffffff816e282b>] do_page_fault+0x4db/0x570
: [<ffffffff816d0dc7>] ? printk_emit+0x31/0x33
: [<ffffffff8143b242>] ? __dev_printk+0x152/0x280
: [<ffffffff813500cd>] ? trace_hardirqs_off_thunk+0x3a/0x3c
: [<ffffffff816deb15>] page_fault+0x25/0x30
: [<ffffffff814987c9>] ? ahci_stop_engine+0x29/0x70
: [<ffffffff81499944>] ahci_deinit_port+0x24/0xb0
: [<ffffffff81499ac2>] ahci_init_controller+0xa2/0xf0
: [<ffffffff814973f2>] ahci_pci_init_controller+0x42/0x50
: [<ffffffff81497d42>] ahci_init_one+0x5e2/0xa70
: [<ffffffff816de3df>] ? _raw_spin_unlock_irqrestore+0x3f/0x80
: [<ffffffff813760d9>] local_pci_probe+0x79/0x100
: [<ffffffff81376271>] pci_device_probe+0x111/0x120
: [<ffffffff8143f3eb>] driver_probe_device+0x8b/0x390
: [<ffffffff8143f7a0>] ? __driver_attach+0xb0/0xb0
: [<ffffffff8143f7eb>] __device_attach+0x4b/0x60
: [<ffffffff8143d2de>] bus_for_each_drv+0x4e/0xa0
: [<ffffffff8143f2f8>] device_attach+0xa8/0xc0
: [<ffffffff8143dfcb>] bus_rescan_devices_helper+0x4b/0x80
: [<ffffffff8143e02a>] store_drivers_probe+0x2a/0x60
: [<ffffffff8124c668>] ? sysfs_write_file+0xc8/0x150
: [<ffffffff8143d087>] bus_attr_store+0x27/0x30
: [<ffffffff8124c680>] sysfs_write_file+0xe0/0x150
: [<ffffffff811cf6cf>] vfs_write+0xaf/0x190
: [<ffffffff811cfa0d>] sys_write+0x4d/0x90
: [<ffffffff816e7369>] system_call_fastpath+0x16/0x1b
Comment 1 Josh Boyer 2012-11-12 16:00:44 EST

*** This bug has been marked as a duplicate of bug 863653 ***

Note You need to log in before you can comment on or make changes to this bug.