Bug 863673 - [abrt] ibus-1.4.99.20120914-2.fc18: locale.py:539:setlocale:Error: unsupported locale setting
[abrt] ibus-1.4.99.20120914-2.fc18: locale.py:539:setlocale:Error: unsupporte...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:7f9e4c203e8151b57bc8cf91f12...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 11:03 EDT by efreeti
Modified: 2012-12-20 11:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:02:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: event_log (36 bytes, text/plain)
2012-10-06 11:03 EDT, efreeti
no flags Details
File: core_backtrace (178 bytes, text/plain)
2012-10-06 11:03 EDT, efreeti
no flags Details

  None (edit)
Description efreeti 2012-10-06 11:03:04 EDT
Description of problem:
Fresh installation of F18 beta TC2. Clicking on input method selector gives error. Attempting to click on "preference" raised crash report filing

Version-Release number of selected component:
ibus-1.4.99.20120914-2.fc18

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        /usr/bin/python /usr/share/ibus/setup/main.py
kernel:         3.6.0-1.fc18.x86_64

backtrace:
:locale.py:539:setlocale:Error: unsupported locale setting
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/setup/main.py", line 677, in <module>
:    locale.setlocale(locale.LC_ALL, '')
:  File "/usr/lib64/python2.7/locale.py", line 539, in setlocale
:    return _setlocale(category, locale)
:Error: unsupported locale setting
:
:Local variables in innermost frame:
:locale: ''
:category: 6
Comment 1 efreeti 2012-10-06 11:03:06 EDT
Created attachment 622734 [details]
File: event_log
Comment 2 efreeti 2012-10-06 11:03:09 EDT
Created attachment 622735 [details]
File: core_backtrace
Comment 3 fujiwara 2012-10-11 02:09:05 EDT
(In reply to comment #0)

Probably it's good to fix this. But which locale did you run ibus-setup on?

I can not reproduce your problem even though LANG is removed.

% env LANG= ibus-setup
Comment 4 Fedora Update System 2012-10-11 09:18:42 EDT
ibus-1.4.99.20121006-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-15547/ibus-1.4.99.20121006-2.fc18
Comment 5 Fedora Update System 2012-10-11 09:30:19 EDT
ibus-1.4.99.20121006-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-15571/ibus-1.4.99.20121006-2.fc17
Comment 6 efreeti 2012-10-11 11:35:26 EDT
I have my F18 latest updated. ibus-setup gives a gui menu, leaving the following messages in terminal:

$ ibus-setup

(main.py:7180): IBUS-WARNING **: org.freedesktop.IBus.Config.GetValue: GDBus.Error:org.freedesktop.DBus.Error.Failed: Config value [general:load_xkb_layouts] does not exist.

(main.py:7180): IBUS-WARNING **: org.freedesktop.IBus.Config.GetValue: GDBus.Error:org.freedesktop.DBus.Error.Failed: Config value [general/xkblayoutconfig:group_list] does not exist.


I don't really see how changing the settings of menu will let me use other input language (I select Chinese-intelligent pinyin as input method). Shortcut key doesn't work. My default locale is US english, if that is what you are asking.


As for input method selector from applications menu, choosing "Use IBus (recommended)" now gives the following message:

GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._imsettings_2derror_2dquark.Code5: Current desktop isn't targeted by Input Method.
Comment 7 Fedora Update System 2012-10-11 13:19:39 EDT
Package ibus-1.4.99.20121006-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.4.99.20121006-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15547/ibus-1.4.99.20121006-2.fc18
then log in and leave karma (feedback).
Comment 8 fujiwara 2012-10-11 22:23:36 EDT
(In reply to comment #6)
> I have my F18 latest updated. ibus-setup gives a gui menu, leaving the
> following messages in terminal:
> 
> $ ibus-setup
> 
> (main.py:7180): IBUS-WARNING **: org.freedesktop.IBus.Config.GetValue:
> GDBus.Error:org.freedesktop.DBus.Error.Failed: Config value
> [general:load_xkb_layouts] does not exist.
> 
> (main.py:7180): IBUS-WARNING **: org.freedesktop.IBus.Config.GetValue:
> GDBus.Error:org.freedesktop.DBus.Error.Failed: Config value
> [general/xkblayoutconfig:group_list] does not exist.


It's another problem.
As you see, this bug is updated and ibus-1.4.99.20121006-2.fc18 is available now and I think the [general:load_xkb_layouts] issue is fixed.

But I'm asking the original bug instead:

(In reply to comment #0)
> backtrace:
> :locale.py:539:setlocale:Error: unsupported locale setting

Which locale did you use to see this problem?
I guess you set a wrong locale or an anaconda bug.


> I don't really see how changing the settings of menu will let me use other
> input language (I select Chinese-intelligent pinyin as input method).
> Shortcut key doesn't work. My default locale is US english, if that is what
> you are asking.

If you use gnome-shell instead of metacity + gnome-panel, you need to run 'gnome-control-center region' instead of ibus-setup because ibus is integrated into GNOME3.
ibus-setup needs to be called for non-GNOME desktops or metacity + gnome-panel.


> As for input method selector from applications menu, choosing "Use IBus
> (recommended)" now gives the following message:
> 
> GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._imsettings_2derror_2dquark.
> Code5: Current desktop isn't targeted by Input Method.

I don't see the error but I guess you use gnome-shell.
Comment 9 fujiwara 2012-10-11 22:28:56 EDT
BTW, to check the current locale, 'locale' command is good.
Comment 10 efreeti 2012-10-20 00:12:13 EDT
> But I'm asking the original bug instead:
> 
> (In reply to comment #0)
> > backtrace:
> > :locale.py:539:setlocale:Error: unsupported locale setting
> 
> Which locale did you use to see this problem?
> I guess you set a wrong locale or an anaconda bug.
> 
I believe this problem is fixed after the latest update. The crash never occur anymore.

> If you use gnome-shell instead of metacity + gnome-panel, you need to run
> 'gnome-control-center region' instead of ibus-setup because ibus is
> integrated into GNOME3.
> ibus-setup needs to be called for non-GNOME desktops or metacity +
> gnome-panel.

Unless I'm very wrong, I thought the purpose of having an icon in the apps menu is to free me from the burden of remembering every command and of typing into the terminal just to start an application?

Or maybe I have used the wrong application here, because going to the menus and click "input method selector" is just a natural destination if I want to switch keyboard language. Btw after your reminder I can now set another keyboard language in gnome-control-center->Region and Language, but honestly this is a sucky experience. Hope this will be fixed in future.
Comment 11 fujiwara 2012-10-21 21:44:26 EDT
(In reply to comment #10)
> > But I'm asking the original bug instead:
> > 
> > (In reply to comment #0)
> > > backtrace:
> > > :locale.py:539:setlocale:Error: unsupported locale setting
> > 
> > Which locale did you use to see this problem?
> > I guess you set a wrong locale or an anaconda bug.
> > 
> I believe this problem is fixed after the latest update. The crash never
> occur anymore.
> 
> > If you use gnome-shell instead of metacity + gnome-panel, you need to run
> > 'gnome-control-center region' instead of ibus-setup because ibus is
> > integrated into GNOME3.
> > ibus-setup needs to be called for non-GNOME desktops or metacity +
> > gnome-panel.
> 
> Unless I'm very wrong, I thought the purpose of having an icon in the apps
> menu is to free me from the burden of remembering every command and of
> typing into the terminal just to start an application?

I'm asking the result of the 'locale' command to know the root cause and why this problem could be happend.
The purpose does not mean to fix ibus itself, I think.
Comment 12 efreeti 2012-10-21 21:46:03 EDT
(In reply to comment #11)
> (In reply to comment #10)
> > > But I'm asking the original bug instead:
> > > 
> > > (In reply to comment #0)
> > > > backtrace:
> > > > :locale.py:539:setlocale:Error: unsupported locale setting
> > > 
> > > Which locale did you use to see this problem?
> > > I guess you set a wrong locale or an anaconda bug.
> > > 
> > I believe this problem is fixed after the latest update. The crash never
> > occur anymore.
> > 
> > > If you use gnome-shell instead of metacity + gnome-panel, you need to run
> > > 'gnome-control-center region' instead of ibus-setup because ibus is
> > > integrated into GNOME3.
> > > ibus-setup needs to be called for non-GNOME desktops or metacity +
> > > gnome-panel.
> > 
> > Unless I'm very wrong, I thought the purpose of having an icon in the apps
> > menu is to free me from the burden of remembering every command and of
> > typing into the terminal just to start an application?
> 
> I'm asking the result of the 'locale' command to know the root cause and why
> this problem could be happend.
> The purpose does not mean to fix ibus itself, I think.

$ locale
LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=
Comment 13 fujiwara 2012-10-21 22:16:37 EDT
(In reply to comment #12)
> $ locale
> LANG=en_US.utf8
> LC_CTYPE="en_US.utf8"
> LC_NUMERIC="en_US.utf8"
> LC_TIME="en_US.utf8"
> LC_COLLATE="en_US.utf8"
> LC_MONETARY="en_US.utf8"
> LC_MESSAGES="en_US.utf8"
> LC_PAPER="en_US.utf8"
> LC_NAME="en_US.utf8"
> LC_ADDRESS="en_US.utf8"
> LC_TELEPHONE="en_US.utf8"
> LC_MEASUREMENT="en_US.utf8"
> LC_IDENTIFICATION="en_US.utf8"
> LC_ALL=

OK, thanks.
AFAIK, it's the anaconda's bug 858591.
The installer system should provide en_US.utf8.

But this fix will launch ibus-setup with the wrong locale.
Comment 14 Fedora Update System 2012-12-20 11:02:26 EST
ibus-1.4.99.20121006-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.