Bug 863691 - f18b tc2 anaconda cannot create a bios boot partition (BIOS system using GPT disk and GRUB2 installed to such partition)
f18b tc2 anaconda cannot create a bios boot partition (BIOS system using GPT ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 12:19 EDT by Reartes Guillermo
Modified: 2013-12-19 13:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 13:58:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (3.18 KB, text/plain)
2012-10-06 12:19 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-06 12:19:41 EDT
Created attachment 622764 [details]
anaconda.log

Description of problem:

I tried to create a bios_boot partition and anaconda failed saying
that there is no free space. (tried with up to tree un-partitioned disks)

Version-Release number of selected component (if applicable):
f18b tc2, anaconda 18.12

How reproducible:
always

Steps to Reproduce:
1. boot, enter storage, select disks, manual partitioning
2. try to create a bios_boot partition (type biosboot in mount point dialog
and choose 1mb size).
  
Actual results:
no bios boot partition

Expected results:
bios boot partition

Additional info:
tried booting with the disk unpartitioned
tried booting with the disk msdos partitioned
tried booting with the disk gpt partitioned

is this a bug or just a wrong error message (or other)?
Comment 1 Brian Lane 2012-10-25 20:01:24 EDT
Please try again with TC6. Also, biosboot on a msdos disk has no meaning, it will make a partition for you, but it won't use it.
Comment 2 Reartes Guillermo 2012-10-25 21:46:40 EDT
With F18b TC6 there is no message nor error when creating a bios boot partition. However, while installabe and bootable, the default result does not look acceptable. 

Do you want me to open another bug-report so this can be closed?

Anaconda will still not create a bios boot partition by default. (anaconda will silently do other stuff).
Comment 3 Brian Lane 2012-10-25 22:05:20 EDT
What do you mean by 'does not look acceptable'?

And how are you testing? biosboot will only be created on GPT disks used on BIOS machines. I test this by passing gpt on the kernel cmdline to force it to use GPT on my small virt disk.
Comment 4 Reartes Guillermo 2012-10-25 22:21:09 EDT
I was aware of the gpt boot parameter.

A disk with a gpt disk label and no gpt boot parameter results in anaconda removing the gpt disk label and creating a msdos disk label and 3 primary partitions. (the biosboot, root and swap).

Also there is no warning nor feedback that you are not doing what is expected.
I mean, if you booted in bios (no gpt parameter) anaconda should at least warn you that it will do something undesired. (like wasting a primary partition).

Also even if booting with a gpt partitioned disk (and no gpt parameter) it is highly questionable to remove the gpt disk label and replacing it with a msdos one and wasting one primary partition).

the gpt boot parameter is needed even for gpt partitioned disks (but with no partitions).

Note You need to log in before you can comment on or make changes to this bug.