Bug 863720 - Missing font dependency
Missing font dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vdr (Show other bugs)
18
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 17:35 EDT by Dirk Nehring
Modified: 2012-12-22 12:55 EST (History)
2 users (show)

See Also:
Fixed In Version: vdr-1.7.31-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-22 12:55:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dirk Nehring 2012-10-06 17:35:50 EDT
Description of problem:
vdr has a buildin OSD display. For rendering a OSD, vdr uses system fonts. Minimum requirements are:

Requires:       dejavu-sans-fonts dejavu-sans-mono-fonts

I found this after installing vdr on a minimal system.
Comment 1 Ville Skyttä 2012-10-07 04:34:21 EDT
Those are not the minimum requirements, vdr doesn't require a specific font. Instead of dejavu one might want to use vdrsymbol fonts etc.

The problem is that there's no way to depend on let's say *some* (not a particular) sans-serif and some monospace font. Requiring "font(:lang=en)" is the closest we have, but that's insufficient as well. So I don't think this is sanely fixable at the moment.
Comment 2 Ville Skyttä 2012-12-22 12:30:02 EST
On the other hand I don't think font(:lang=en) hurts anything, so I'm going to add a dep on that.

Note You need to log in before you can comment on or make changes to this bug.