Bug 863755 - Dependency of python3-scipy is screwed up.
Dependency of python3-scipy is screwed up.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scipy (Show other bugs)
18
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Jef Spaleta
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 05:05 EDT by fedvasu
Modified: 2013-02-26 21:39 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-26 21:39:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fedvasu 2012-10-07 05:05:07 EDT
Description of problem:
Dependency of python3-scipy is screwed up.
python3-scipy must depend on python3-numpy , but it doesn't and yum installs python3-scipy without numpy but when one imports scipy one gets error.

import scipy as sp
error numpy not found

Version-Release number of selected component (if applicable):
I have tested this on fedora 18 alpha.

How reproducible:
yum install python3-scipy 

Steps to Reproduce:
1.type on cmd-line 'python3' 
2.import scipy 
3.error there is no module numpy
  
Actual results:
1.python3-numpy is not part of dependency of python3-scipy,which leads to
module import error.

Expected results:
1.python3-numpy must be part of dependency of python3-scipy

Additional info:
This dependency problem doesn't apply to python-scipy.
Comment 1 fedvasu 2012-10-07 08:36:48 EDT
ofcourse very trivial fix to this problem is installing pyhton3-numpy seperately(manually).

"yum install python3-numpy".
Comment 2 fedvasu 2012-10-07 08:37:41 EDT
it is not fix rather "trivial workaround".
Comment 3 Bohuslav "Slavek" Kabrda 2012-10-08 02:46:51 EDT
Reassigning to scipy, this is not a problem of python3 package.
Comment 4 fedvasu 2012-10-08 15:17:49 EDT
(In reply to comment #3)
> Reassigning to scipy, this is not a problem of python3 package.

who said anything about it being problem of python3 package?

I clearly mentioned "python3-scipy" everywhere.I genuinely feel your remark is bizzare, care to elaborate why it was assigned to python3 in the first place?
Comment 5 Orion Poplawski 2012-10-08 15:36:49 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > Reassigning to scipy, this is not a problem of python3 package.
> 
> who said anything about it being problem of python3 package?

You filed it against the python3 package.

New builds underway.
Comment 6 fedvasu 2012-10-09 05:07:50 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > Reassigning to scipy, this is not a problem of python3 package.
> > 
> > who said anything about it being problem of python3 package?
> 
> You filed it against the python3 package.
> 
> New builds underway.

yes,I remember , I had to give a mandatory package to file a bug against , but bugzilla didn't provide python3-scipy package in the package list to file a bug against.
Comment 7 Orion Poplawski 2012-10-09 10:50:16 EDT
(In reply to comment #6)
> yes,I remember , I had to give a mandatory package to file a bug against ,
> but bugzilla didn't provide python3-scipy package in the package list to
> file a bug against.

bugzilla only lists source packages.  If you do "rpm -qi python3-scipy" it will tell you what source package it comes from.  My scipy builds failed - unfortunately the python3 numpy/scipy stuff is pretty fragile at the moment.  But the fix is at least checked in.
Comment 8 fedvasu 2013-02-12 14:18:23 EST
guys, this bug still remains, I think it is not a priority to support scipy for you guys, but please fix this issue, it is important to some of us!
I am ready to help in any possible way to fix this issue except maintaining the packages.

I seriously do not want to whine or criticise anyone, but this should have been fixed before fedora 18 release. 

I have tested this(again) on fresh fedora 18 (G3 shell) install.

or atleast say WONT FIX.

ps: how to escalate bug reports?
Comment 9 Orion Poplawski 2013-02-13 00:29:13 EST
Couple comments -

- Python 3.3 support seems to be *barely* and just recently expected in numpy and scipy
- scipy has been crashing running its tests under python3, which is what has been holding things up.  This led me to believe that using scipy with python3 is a dubious thing at best, hence the lack of priority.
- We're (mostly) volunteers here.  I'm giving up quality time with my wife this evening to answer this.  You're more than welcome to help maintain it as well, and in fact in this case is the only help that would be useful.  As you perhaps can tell, we could use the help.
- Escalate?  See previous.
- We have every intention of fixing this.  In fact, the (hopeful) fix had been checked in quite a while ago.  If the damn thing had built cleanly, it would have been out the door a while ago as well.

So, in an attempt to get this resolved I'm doing some builds with the python3 tests disabled.  I'll try to get an update out tomorrow, but I'm going to bed now.  Just be aware that certain python3 tests were crashing with memory allocation errors, so I'd be suspicious of the whole thing.
Comment 10 Fedora Update System 2013-02-13 11:13:59 EST
scipy-0.11.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/scipy-0.11.0-3.fc18
Comment 11 Toshio Ernie Kuratomi 2013-02-13 20:29:38 EST
(In reply to comment #8)
> I am ready to help in any possible way to fix this issue except maintaining
> the packages.

If you could fix the failing tests and submit a patch, that would be an immense help.
Comment 12 Fedora Update System 2013-02-13 21:28:20 EST
Package scipy-0.11.0-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing scipy-0.11.0-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2421/scipy-0.11.0-3.fc18
then log in and leave karma (feedback).
Comment 13 Orion Poplawski 2013-02-13 22:35:34 EST
FYI - bug report on failing test is bug #910962
Comment 14 fedvasu 2013-02-15 14:24:49 EST
(In reply to comment #13)
> FYI - bug report on failing test is bug #910962

thank you Orion.

I will test it.

I apologize for my harsh words, I respect what you do, unfortunately can't do much to shoulder your burden, as yet.

[too much of burdening the shoulder :(]
Comment 15 fedvasu 2013-02-15 14:36:49 EST
(In reply to comment #11)
> (In reply to comment #8)
> > I am ready to help in any possible way to fix this issue except maintaining
> > the packages.
> 
> If you could fix the failing tests and submit a patch, that would be an
> immense help.

Hmm, will track upstream, from now on and if I find any patch for failing tests there(like quite a few failing), will submit here at the earliest(with full description of severity and functionality ofcourse).

FYI,Orion found fix in one of the commits upstream.

Thats all I could do for now.
Comment 16 fedvasu 2013-02-15 15:08:39 EST
Ironically, the upstream fortran code, also had subroutine, level dependency issues :).

seriously its LOLZ!

test results:
It works like a charm, uninstalled python3-numpy(which also removed python3-matplotlib, now in the process of reinstalling matplotlib) and did 'yum install --enablerepo=updates-testing python3-scipy' installs python3-numpy and python3-numpy-f2py as dependencies (all other deps were present)

so +1 for the fix.
Comment 17 Fedora Update System 2013-02-16 22:34:07 EST
Package scipy-0.11.0-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing scipy-0.11.0-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2421/scipy-0.11.0-4.fc18
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2013-02-26 21:39:40 EST
scipy-0.11.0-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.