Bug 863773 - Long Mouse Click to move Windows or execute Drag&Drop operations doesn't work on Thinkpad T430
Long Mouse Click to move Windows or execute Drag&Drop operations doesn't work...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 06:58 EDT by Michael
Modified: 2013-07-10 08:45 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 03:45:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"dmesg | grep -i syn" and "synclient" output (2.64 KB, text/plain)
2012-10-07 06:58 EDT, Michael
no flags Details

  None (edit)
Description Michael 2012-10-07 06:58:57 EDT
Created attachment 622963 [details]
"dmesg | grep -i syn" and "synclient" output

Description of problem:
Thinkpad T430 with Fedora 17 and all updates.
The Thinkpad has two left mouse buttons, one for the trackpoint and another one for the touchpad. If I use the lower one (the one which should be used with the touchpad) I'm not able to move windows, mark text and I also can't use Drag&Drop gestures. It seems as if something is immediately releasing the pressed state of the button.

And now a few other strange things about this bug
1) Everything works with the second left mouse button (the one for the trackpoint).
2) If I put the notebook into the suspend-mode and start it again everything works without any problems with both mouse buttons!
3) If I just hold down the button for a long time all these things can be executed too but this only sporadically works.
4) I tried to downgrade to the synaptics driver 1.6.0 which was on the original  installation media but that didn't solve the problem, so the problem could also exist in another component.

Version-Release number of selected component (if applicable):
xorg-x11-drv-synaptics 1.6.x

How reproducible:
Simply installing all updates on the Lenovo Thinkpad T430 Notebook.
  
Actual results:
Doesn't work.

Expected results:
Should work :-).

Additional info:
Problem doesn't occur if I use the Fedora 17 or 18 live discs.

I know it's a really strange bug. I'll install the newest fedora 18 nightly-build on a second hdd and check if it still works on the installed fedora 18 including all udpates.

nice regards
Comment 1 Michael 2012-10-07 17:32:35 EDT
I did some additional tests:

I installed fedora 17 on a second hdd and installed all updates. I tried to reproduce the problem by updating every package separately but I couldn't reproduce it anymore but in contrast to what I posted in the first post, I had the problem in the fedora 18 live disk too once...

And another News:
* I can fix the problem by simply logging out and in again. I start to believe that the problem has something to do with the gnome-shell...
Comment 2 Michael 2012-10-08 07:42:58 EDT
Another update I did reproduce the bug with XFCE4 too so it's not the fault of the gnome-shell.
I also had the problem once with fedora 17 without any updates.
Comment 3 Michael 2012-10-23 03:45:23 EDT
I didn't have the problem in the last few days... It seems some update fixed the problem... I'll update this bug report in case I can reproduce the problem again...
Comment 4 Soren Wacker 2013-07-10 08:45:47 EDT
I am having the same problem at the moment on a T420s and F19.

Note You need to log in before you can comment on or make changes to this bug.