Bug 863814 - [abrt] gparted-0.12.0-2.fc17: gdk_window_set_geometry_hints: Process /usr/sbin/gpartedbin was killed by signal 11 (SIGSEGV)
[abrt] gparted-0.12.0-2.fc17: gdk_window_set_geometry_hints: Process /usr/sbi...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gparted (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
abrt_hash:630effd68f48323fbae8c72a9e1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 11:43 EDT by Thomas Neuber
Modified: 2013-03-12 04:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 04:46:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (5.02 KB, text/plain)
2012-10-07 11:43 EDT, Thomas Neuber
no flags Details
File: environ (310 bytes, text/plain)
2012-10-07 11:43 EDT, Thomas Neuber
no flags Details
File: backtrace (134.83 KB, text/plain)
2012-10-07 11:43 EDT, Thomas Neuber
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-07 11:43 EDT, Thomas Neuber
no flags Details
File: cgroup (130 bytes, text/plain)
2012-10-07 11:43 EDT, Thomas Neuber
no flags Details
File: maps (37.01 KB, text/plain)
2012-10-07 11:43 EDT, Thomas Neuber
no flags Details
File: dso_list (7.59 KB, text/plain)
2012-10-07 11:43 EDT, Thomas Neuber
no flags Details
File: var_log_messages (328 bytes, text/plain)
2012-10-07 11:43 EDT, Thomas Neuber
no flags Details
File: open_fds (236 bytes, text/plain)
2012-10-07 11:43 EDT, Thomas Neuber
no flags Details

  None (edit)
Description Thomas Neuber 2012-10-07 11:43:17 EDT
Description of problem:
1. create partition table of type GPT
2. create a new partition without filesystem, because it will be marked with flag lvm or raid later.
3. finalize action 2, it will reload the disk layout.

The system contains further disks with msdos partition tables. The disks are used in two (auto-)raid devices. The software reports errors during startup that it is not able to analyse these two devices.


Version-Release number of selected component:
gparted-0.12.0-2.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        /usr/sbin/gpartedbin
crash_function: gdk_window_set_geometry_hints
kernel:         3.5.4-2.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 gdk_window_set_geometry_hints at gdkwindow-x11.c:2361
: #1 gtk_window_move_resize at gtkwindow.c:6219
: #2 gtk_window_check_resize at gtkwindow.c:5408
: #4 _g_closure_invoke_va at gclosure.c:840
: #7 gtk_container_idle_sizer at gtkcontainer.c:1357
: #12 g_main_context_iteration at gmain.c:3207
: #13 gtk_main_iteration_do at gtkmain.c:1358
: #14 Gtk::Main::iteration_impl at main.cc:549
: #15 GParted::Win_GParted::show_pulsebar at Win_GParted.cc:628
: #16 GParted::Win_GParted::menu_gparted_refresh_devices at Win_GParted.cc:1193
Comment 1 Thomas Neuber 2012-10-07 11:43:21 EDT
Created attachment 623000 [details]
File: core_backtrace
Comment 2 Thomas Neuber 2012-10-07 11:43:23 EDT
Created attachment 623001 [details]
File: environ
Comment 3 Thomas Neuber 2012-10-07 11:43:28 EDT
Created attachment 623002 [details]
File: backtrace
Comment 4 Thomas Neuber 2012-10-07 11:43:30 EDT
Created attachment 623003 [details]
File: limits
Comment 5 Thomas Neuber 2012-10-07 11:43:32 EDT
Created attachment 623004 [details]
File: cgroup
Comment 6 Thomas Neuber 2012-10-07 11:43:35 EDT
Created attachment 623005 [details]
File: maps
Comment 7 Thomas Neuber 2012-10-07 11:43:37 EDT
Created attachment 623006 [details]
File: dso_list
Comment 8 Thomas Neuber 2012-10-07 11:43:39 EDT
Created attachment 623007 [details]
File: var_log_messages
Comment 9 Thomas Neuber 2012-10-07 11:43:41 EDT
Created attachment 623008 [details]
File: open_fds
Comment 10 Fedora Update System 2013-02-22 11:56:54 EST
gparted-0.14.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gparted-0.14.1-1.fc17
Comment 11 Fedora Update System 2013-02-24 03:44:28 EST
Package gparted-0.14.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gparted-0.14.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2942/gparted-0.14.1-1.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-03-12 04:46:53 EDT
gparted-0.14.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.