Bug 863823 - Disable window management shortcuts
Disable window management shortcuts
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 864491 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 13:14 EDT by Christoph Wickert
Modified: 2013-03-12 10:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: lorax-18.21-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:15:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2012-10-07 13:14:15 EDT
Description of problem:
Anaconda has 4 workspaces, it should only have one.

Version-Release number of selected component (if applicable):
F18 Beta TC2 (not sure what anaconda version this is, 'rpm -q anaconda returns' nothing).

How reproducible:
always

Steps to Reproduce:
1. Start F18 Beta TC2
2. In anaconda, press CTRL+ALT+Arrow right

Actual results:
The desktop switches to a workspace 2. There are 4 in total, anaconda runs on #1 and the other 3 are black.

Expected results:
Keyboard shortcuts for switching workspaces should be disabled.
Comment 1 Christoph Wickert 2012-10-07 17:01:47 EDT
I just noticed that ALT+TAB works, too. I guess all window management shortcuts should be disabled except possibly CTRL+ALT+D to open the desktop or in this case the main hub.
Comment 2 Chris Lumens 2012-10-08 10:06:50 EDT
Yeah there's likely to be several of these.  If you happen to know the gschema settings for these, we can patch lorax to disable them.
Comment 3 Christoph Wickert 2012-10-08 12:18:00 EDT
You can look everything up in 
/usr/share/glib-2.0/schemas/org.gnome.desktop.wm.keybindings.gschema.xml
Comment 4 Chris Lumens 2012-10-09 10:02:22 EDT
*** Bug 864491 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2012-10-11 14:22:02 EDT
lorax-18.21-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lorax-18.21-1.fc18
Comment 6 Fedora Update System 2012-10-12 13:52:38 EDT
Package lorax-18.21-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-18.21-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15993/lorax-18.21-1.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-12-20 11:15:08 EST
lorax-18.21-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.