Bug 863834 - default x86-64 gcc install includes broken symlink to 32-bit libgcc_s.so
default x86-64 gcc install includes broken symlink to 32-bit libgcc_s.so
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
18
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 15:29 EDT by Frank Ch. Eigler
Modified: 2012-10-07 15:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-07 15:34:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2012-10-07 15:29:13 EDT
gcc-4.7.2-3.fc18.x86_64 includes this file, which is actually a symlink:

/usr/lib/gcc/x86_64-redhat-linux/4.7.2/32/libgcc_s.so -> /lib/libgcc_s.so.1

This symlink is broken (gcc -m32 fails) unless libgcc.i686 is manually installed.
Perhaps libgcc.i686 should be a prereq of the main x86-64 gcc package.  Or 
perhaps the /32/ multilib files should not be in the base rpm.
Comment 1 Jakub Jelinek 2012-10-07 15:34:53 EDT
This is by design.  Prereq of i686 packages in x86_64 devel packages is highly undesirable (many people don't need/want -m32 support and don't want any i686.rpm packages installed).
And moving stuff to a different package wouldn't help in any way, gcc -m32 would still fail unless you install the needed 32-bit devel support (libgcc.i686, glibc-devel.i686, libstdc++-devel.i686 or more).

Note You need to log in before you can comment on or make changes to this bug.