Bug 863846 - SELinux is preventing /usr/bin/bash from 'getattr' accesses on the file /usr/sbin/consoletype.
SELinux is preventing /usr/bin/bash from 'getattr' accesses on the file /usr/...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:89dc59afdc0740fa041dd0ba29f...
:
: 863847 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 16:30 EDT by Nicolas Chauvet (kwizart)
Modified: 2012-12-10 16:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 16:39:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-07 16:30 EDT, Nicolas Chauvet (kwizart)
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-07 16:30 EDT, Nicolas Chauvet (kwizart)
no flags Details

  None (edit)
Description Nicolas Chauvet (kwizart) 2012-10-07 16:30:50 EDT
Additional info:
libreport version: 2.0.15
kernel:         3.6.0-3.fc18.i686.PAE

description:
:SELinux is preventing /usr/bin/bash from 'getattr' accesses on the file /usr/sbin/consoletype.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If vous pensez que bash devrait être autorisé à accéder getattr sur consoletype file par défaut.
:Then vous devriez rapporter ceci en tant qu'anomalie.
:Vous pouvez générer un module de stratégie local pour autoriser cet accès.
:Do
:autoriser cet accès pour le moment en exécutant :
:# grep dhclient-script /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:system_r:dhcpc_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:consoletype_exec_t:s0
:Target Objects                /usr/sbin/consoletype [ file ]
:Source                        dhclient-script
:Source Path                   /usr/bin/bash
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           bash-4.2.37-6.fc18.i686
:Target RPM Packages           initscripts-9.40-1.fc18.i686
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc6.git0.2.fc18.i686.PAE
:                              #1 SMP Mon Sep 17 17:28:04 UTC 2012 i686 i686
:Alert Count                   31
:First Seen                    2012-10-07 13:57:15 CEST
:Last Seen                     2012-10-07 13:58:01 CEST
:Local ID                      0da37eed-1e14-4757-9d7b-391d1efc412c
:
:Raw Audit Messages
:type=AVC msg=audit(1349611081.289:132): avc:  denied  { getattr } for  pid=2794 comm="dhclient-script" path="/usr/sbin/consoletype" dev="sda3" ino=675360 scontext=unconfined_u:system_r:dhcpc_t:s0-s0:c0.c1023 tcontext=system_u:object_r:consoletype_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1349611081.289:132): arch=i386 syscall=stat64 success=no exit=EACCES a0=9df38d0 a1=bfee72a0 a2=44bb3000 a3=9df38d0 items=0 ppid=2793 pid=2794 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=2 comm=dhclient-script exe=/usr/bin/bash subj=unconfined_u:system_r:dhcpc_t:s0-s0:c0.c1023 key=(null)
:
:Hash: dhclient-script,dhcpc_t,consoletype_exec_t,file,getattr
:
:audit2allow
:
:#============= dhcpc_t ==============
:allow dhcpc_t consoletype_exec_t:file getattr;
:
:audit2allow -R
:
:#============= dhcpc_t ==============
:allow dhcpc_t consoletype_exec_t:file getattr;
:
Comment 1 Nicolas Chauvet (kwizart) 2012-10-07 16:30:54 EDT
Created attachment 623104 [details]
File: type
Comment 2 Nicolas Chauvet (kwizart) 2012-10-07 16:30:55 EDT
Created attachment 623105 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-08 04:16:35 EDT
*** Bug 863847 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2012-10-08 04:24:58 EDT
Fixed in selinux-policy-3.11.1-33.fc18.noarch

commit 10dede6526768e6b712e085491cefef39e6209b0
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Mon Oct 8 10:24:00 2012 +0200

    Allow dhcpc to execute consoletype
Comment 5 Fedora Update System 2012-10-11 05:04:34 EDT
selinux-policy-3.11.1-36.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-36.fc18
Comment 6 Fedora Update System 2012-10-11 13:23:10 EDT
Package selinux-policy-3.11.1-36.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-36.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15934/selinux-policy-3.11.1-36.fc18
then log in and leave karma (feedback).

Note You need to log in before you can comment on or make changes to this bug.