Bug 863849 - SELinux is preventing /usr/bin/mandb from 'write' accesses on the directory man.
SELinux is preventing /usr/bin/mandb from 'write' accesses on the directory man.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f1fb3bc8631a3800db7e6cf8726...
:
: 863848 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 16:32 EDT by Nicolas Chauvet (kwizart)
Modified: 2012-10-08 04:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 04:28:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-07 16:32 EDT, Nicolas Chauvet (kwizart)
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-07 16:32 EDT, Nicolas Chauvet (kwizart)
no flags Details

  None (edit)
Description Nicolas Chauvet (kwizart) 2012-10-07 16:32:49 EDT
Additional info:
libreport version: 2.0.15
kernel:         3.6.0-3.fc18.i686.PAE

description:
:SELinux is preventing /usr/bin/mandb from 'write' accesses on the directory man.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If vous pensez que mandb devrait être autorisé à accéder write sur man directory par défaut.
:Then vous devriez rapporter ceci en tant qu'anomalie.
:Vous pouvez générer un module de stratégie local pour autoriser cet accès.
:Do
:autoriser cet accès pour le moment en exécutant :
:# grep mandb /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:mandb_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:man_t:s0
:Target Objects                man [ dir ]
:Source                        mandb
:Source Path                   /usr/bin/mandb
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           man-db-2.6.2-5.fc18.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-21.fc18.noarch selinux-
:                              policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc6.git0.2.fc18.i686.PAE
:                              #1 SMP Mon Sep 17 17:28:04 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    2012-10-06 09:16:03 CEST
:Last Seen                     2012-10-06 09:16:03 CEST
:Local ID                      e7d6b218-04a3-4f29-ad83-bee3d0f9e1b4
:
:Raw Audit Messages
:type=AVC msg=audit(1349507763.750:80): avc:  denied  { write } for  pid=2505 comm="mandb" name="man" dev="sda3" ino=524299 scontext=system_u:system_r:mandb_t:s0-s0:c0.c1023 tcontext=system_u:object_r:man_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1349507763.750:80): avc:  denied  { add_name } for  pid=2505 comm="mandb" name="CACHEDIR.TAG" scontext=system_u:system_r:mandb_t:s0-s0:c0.c1023 tcontext=system_u:object_r:man_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1349507763.750:80): avc:  denied  { create } for  pid=2505 comm="mandb" name="CACHEDIR.TAG" scontext=system_u:system_r:mandb_t:s0-s0:c0.c1023 tcontext=system_u:object_r:man_t:s0 tclass=file
:
:
:type=AVC msg=audit(1349507763.750:80): avc:  denied  { write } for  pid=2505 comm="mandb" path="/var/cache/man/CACHEDIR.TAG" dev="sda3" ino=526520 scontext=system_u:system_r:mandb_t:s0-s0:c0.c1023 tcontext=system_u:object_r:man_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1349507763.750:80): arch=i386 syscall=open success=yes exit=ESRCH a0=a028ec8 a1=8241 a2=1b6 a3=a02ceb0 items=0 ppid=2500 pid=2505 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=3 comm=mandb exe=/usr/bin/mandb subj=system_u:system_r:mandb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: mandb,mandb_t,man_t,dir,write
:
:audit2allow
:
:#============= mandb_t ==============
:#!!!! The source type 'mandb_t' can write to a 'dir' of the following types:
:# var_t, mandb_cache_t
:
:allow mandb_t man_t:dir { write add_name };
:allow mandb_t man_t:file { write create };
:
:audit2allow -R
:
:#============= mandb_t ==============
:#!!!! The source type 'mandb_t' can write to a 'dir' of the following types:
:# var_t, mandb_cache_t
:
:allow mandb_t man_t:dir { write add_name };
:allow mandb_t man_t:file { write create };
:
Comment 1 Nicolas Chauvet (kwizart) 2012-10-07 16:32:51 EDT
Created attachment 623110 [details]
File: type
Comment 2 Nicolas Chauvet (kwizart) 2012-10-07 16:32:54 EDT
Created attachment 623111 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-08 04:27:16 EDT
*** Bug 863848 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2012-10-08 04:28:43 EDT
Execute in your terminal

# restorecon -R -v /var/cache/man


should fix labeling.

Note You need to log in before you can comment on or make changes to this bug.