Bug 863859 - [abrt] php-cli-5.4.6-2.fc17: __libc_message: Process /usr/bin/php was killed by signal 6 (SIGABRT)
[abrt] php-cli-5.4.6-2.fc17: __libc_message: Process /usr/bin/php was killed ...
Status: CLOSED DUPLICATE of bug 828161
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
abrt_hash:ff289e4daad0f3ac4a5fc45f950...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 17:08 EDT by Nathan A. Mourey II
Modified: 2012-10-08 00:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 00:56:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.21 KB, text/plain)
2012-10-07 17:08 EDT, Nathan A. Mourey II
no flags Details
File: environ (2.43 KB, text/plain)
2012-10-07 17:08 EDT, Nathan A. Mourey II
no flags Details
File: backtrace (29.71 KB, text/plain)
2012-10-07 17:08 EDT, Nathan A. Mourey II
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-07 17:08 EDT, Nathan A. Mourey II
no flags Details
File: cgroup (127 bytes, text/plain)
2012-10-07 17:08 EDT, Nathan A. Mourey II
no flags Details
File: maps (107.22 KB, text/plain)
2012-10-07 17:08 EDT, Nathan A. Mourey II
no flags Details
File: dso_list (23.90 KB, text/plain)
2012-10-07 17:08 EDT, Nathan A. Mourey II
no flags Details
File: var_log_messages (8.40 KB, text/plain)
2012-10-07 17:08 EDT, Nathan A. Mourey II
no flags Details
File: open_fds (179 bytes, text/plain)
2012-10-07 17:08 EDT, Nathan A. Mourey II
no flags Details

  None (edit)
Description Nathan A. Mourey II 2012-10-07 17:08:01 EDT
Description of problem:
did a :
yum install --skip-broken php-\*

When apache would not start the logs pointed out that the php-mapserver was giving error: 

[Sun Oct 07 10:36:57 2012] [notice] Digest: done
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/php_mapscript.so' - /usr/lib64/php/modules/php_mapscript.so: undefined symbol: output_globals in Unknown on line 0
libgcc_s.so.1 must be installed for pthread_cancel to work
[Sun Oct 07 10:40:12 2012] [notice] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0

yum erase php-mapserver

restarted httpd and all worked.

This may or may not be what caused php to break.


Version-Release number of selected component:
php-cli-5.4.6-2.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        /usr/bin/php -C -q -d include_path=/usr/share/pear -d date.timezone=UTC -d output_buffering=1 -d variables_order=EGPCS -d safe_mode=0 -d register_argc_argv=On -d open_basedir= -d auto_prepend_file= -d auto_append_file= /usr/share/pear/pearcmd.php install --nodeps --soft --force --register-only /usr/share/pear/.pkgxml/php-pear-Spreadsheet-Excel-Writer.xml
crash_function: __libc_message
kernel:         3.5.4-2.fc17.x86_64

truncated backtrace:
:Thread no. 1 (8 frames)
: #2 __libc_message at ../sysdeps/unix/sysv/linux/libc_fatal.c:198
: #3 __libc_fatal at ../sysdeps/unix/sysv/linux/libc_fatal.c:209
: #4 pthread_cancel_init at ../nptl/sysdeps/pthread/unwind-forcedunwind.c:65
: #5 _Unwind_ForcedUnwind at ../nptl/sysdeps/pthread/unwind-forcedunwind.c:130
: #6 __pthread_unwind at unwind.c:130
: #7 __do_cancel at pthreadP.h:265
: #8 __pthread_exit at pthread_exit.c:30
: #9 nptl_pthread_exit_hack_handler at /usr/src/debug/mysql-5.5.28/mysys/my_thr_init.c:57
Comment 1 Nathan A. Mourey II 2012-10-07 17:08:05 EDT
Created attachment 623132 [details]
File: core_backtrace
Comment 2 Nathan A. Mourey II 2012-10-07 17:08:06 EDT
Created attachment 623133 [details]
File: environ
Comment 3 Nathan A. Mourey II 2012-10-07 17:08:08 EDT
Created attachment 623134 [details]
File: backtrace
Comment 4 Nathan A. Mourey II 2012-10-07 17:08:10 EDT
Created attachment 623135 [details]
File: limits
Comment 5 Nathan A. Mourey II 2012-10-07 17:08:12 EDT
Created attachment 623136 [details]
File: cgroup
Comment 6 Nathan A. Mourey II 2012-10-07 17:08:14 EDT
Created attachment 623137 [details]
File: maps
Comment 7 Nathan A. Mourey II 2012-10-07 17:08:16 EDT
Created attachment 623138 [details]
File: dso_list
Comment 8 Nathan A. Mourey II 2012-10-07 17:08:18 EDT
Created attachment 623139 [details]
File: var_log_messages
Comment 9 Nathan A. Mourey II 2012-10-07 17:08:19 EDT
Created attachment 623140 [details]
File: open_fds
Comment 10 Remi Collet 2012-10-08 00:56:40 EDT

*** This bug has been marked as a duplicate of bug 828161 ***

Note You need to log in before you can comment on or make changes to this bug.