Bug 863867 - SELinux is preventing /usr/bin/python2.7 from 'getattr' accesses on the directory /etc/gdm.
SELinux is preventing /usr/bin/python2.7 from 'getattr' accesses on the direc...
Status: CLOSED DUPLICATE of bug 863864
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:cd44beb91bd1e1e568ff111c8fe...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 17:52 EDT by Adam Joseph Cook
Modified: 2012-10-08 04:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 04:45:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-07 17:52 EDT, Adam Joseph Cook
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-07 17:52 EDT, Adam Joseph Cook
no flags Details

  None (edit)
Description Adam Joseph Cook 2012-10-07 17:52:40 EDT
Description of problem:
1. Attempted to run 'system-config-kdump'.
2. SELinux raised this issue.


Additional info:
libreport version: 2.0.15
kernel:         3.6.0-3.fc18.x86_64

description:
:SELinux is preventing /usr/bin/python2.7 from 'getattr' accesses on the directory /etc/gdm.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed getattr access on the gdm directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep system-config-k /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:kdumpgui_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:xdm_etc_t:s0
:Target Objects                /etc/gdm [ dir ]
:Source                        system-config-k
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-13.fc18.x86_64
:Target RPM Packages           gdm-3.6.0-1.fc18.x86_64
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-3.fc18.x86_64 #1 SMP Wed Oct
:                              3 13:29:15 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    2012-10-07 16:45:20 CDT
:Last Seen                     2012-10-07 16:45:20 CDT
:Local ID                      2a280cee-b78d-4994-a45e-af7cf27a1a8a
:
:Raw Audit Messages
:type=AVC msg=audit(1349646320.699:194): avc:  denied  { getattr } for  pid=2675 comm="system-config-k" path="/etc/gdm" dev="sda3" ino=1312674 scontext=system_u:system_r:kdumpgui_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_etc_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1349646320.699:194): arch=x86_64 syscall=stat success=no exit=EACCES a0=7fffd486bd50 a1=7fffd486bcc0 a2=7fffd486bcc0 a3=3 items=0 ppid=2674 pid=2675 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=system-config-k exe=/usr/bin/python2.7 subj=system_u:system_r:kdumpgui_t:s0-s0:c0.c1023 key=(null)
:
:Hash: system-config-k,kdumpgui_t,xdm_etc_t,dir,getattr
:
:audit2allow
:
:#============= kdumpgui_t ==============
:allow kdumpgui_t xdm_etc_t:dir getattr;
:
:audit2allow -R
:
:#============= kdumpgui_t ==============
:allow kdumpgui_t xdm_etc_t:dir getattr;
:
Comment 1 Adam Joseph Cook 2012-10-07 17:52:42 EDT
Created attachment 623165 [details]
File: type
Comment 2 Adam Joseph Cook 2012-10-07 17:52:44 EDT
Created attachment 623166 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-08 04:45:09 EDT

*** This bug has been marked as a duplicate of bug 863864 ***

Note You need to log in before you can comment on or make changes to this bug.