Bug 863869 - SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the chr_file urandom.
SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the chr_file...
Status: CLOSED DUPLICATE of bug 863864
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:49304c47d679ef1e3425d1ab0b2...
:
: 863872 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 17:53 EDT by Adam Joseph Cook
Modified: 2012-10-08 04:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 04:45:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-07 17:53 EDT, Adam Joseph Cook
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-07 17:53 EDT, Adam Joseph Cook
no flags Details

  None (edit)
Description Adam Joseph Cook 2012-10-07 17:53:36 EDT
Description of problem:
1. Attempted to run 'system-config-kdump'.
2. SELinux raised this issue.


Additional info:
libreport version: 2.0.15
kernel:         3.6.0-3.fc18.x86_64

description:
:SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the chr_file urandom.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed read access on the urandom chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep system-config-k /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:kdumpgui_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:urandom_device_t:s0
:Target Objects                urandom [ chr_file ]
:Source                        system-config-k
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-13.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-3.fc18.x86_64 #1 SMP Wed Oct
:                              3 13:29:15 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-07 16:45:20 CDT
:Last Seen                     2012-10-07 16:45:20 CDT
:Local ID                      285ad998-3054-4f77-bcc5-0fa32fb529f4
:
:Raw Audit Messages
:type=AVC msg=audit(1349646320.697:186): avc:  denied  { read } for  pid=2675 comm="system-config-k" name="urandom" dev="devtmpfs" ino=1049 scontext=system_u:system_r:kdumpgui_t:s0-s0:c0.c1023 tcontext=system_u:object_r:urandom_device_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1349646320.697:186): arch=x86_64 syscall=open success=no exit=EACCES a0=7f7e584be59a a1=0 a2=1b6 a3=238 items=0 ppid=2674 pid=2675 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=system-config-k exe=/usr/bin/python2.7 subj=system_u:system_r:kdumpgui_t:s0-s0:c0.c1023 key=(null)
:
:Hash: system-config-k,kdumpgui_t,urandom_device_t,chr_file,read
:
:audit2allow
:
:#============= kdumpgui_t ==============
:#!!!! This avc can be allowed using one of the these booleans:
:#     authlogin_nsswitch_use_ldap, global_ssp
:
:allow kdumpgui_t urandom_device_t:chr_file read;
:
:audit2allow -R
:
:#============= kdumpgui_t ==============
:#!!!! This avc can be allowed using one of the these booleans:
:#     authlogin_nsswitch_use_ldap, global_ssp
:
:allow kdumpgui_t urandom_device_t:chr_file read;
:
Comment 1 Adam Joseph Cook 2012-10-07 17:53:41 EDT
Created attachment 623169 [details]
File: type
Comment 2 Adam Joseph Cook 2012-10-07 17:53:42 EDT
Created attachment 623170 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-08 04:33:46 EDT
*** Bug 863872 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2012-10-08 04:45:21 EDT

*** This bug has been marked as a duplicate of bug 863864 ***

Note You need to log in before you can comment on or make changes to this bug.