Bug 863873 - SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the file /etc/my.cnf.
SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the file /et...
Status: CLOSED DUPLICATE of bug 863864
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
: 863866 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2012-10-07 18:10 EDT by Adam Joseph Cook
Modified: 2012-10-08 04:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-10-08 04:45:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-07 18:10 EDT, Adam Joseph Cook
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-07 18:10 EDT, Adam Joseph Cook
no flags Details

  None (edit)
Description Adam Joseph Cook 2012-10-07 18:10:02 EDT
Description of problem:
1. Attempted to run 'system-config-kdump'.
2. SELinux raised this issue.

Additional info:
libreport version: 2.0.15
kernel:         3.6.0-3.fc18.x86_64

:SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the file /etc/my.cnf.
:*****  Plugin catchall (100. confidence) suggests  ***************************
:If you believe that python2.7 should be allowed read access on the my.cnf file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:allow this access for now by executing:
:# grep system-config-k /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:Additional Information:
:Source Context                system_u:system_r:kdumpgui_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:mysqld_etc_t:s0
:Target Objects                /etc/my.cnf [ file ]
:Source                        system-config-k
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-13.fc18.x86_64
:Target RPM Packages           mysql-libs-5.5.28-1.fc18.x86_64
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-3.fc18.x86_64 #1 SMP Wed Oct
:                              3 13:29:15 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-07 17:07:33 CDT
:Last Seen                     2012-10-07 17:07:33 CDT
:Local ID                      db21986c-6779-44ef-a9ec-ddb1d44cf465
:Raw Audit Messages
:type=AVC msg=audit(1349647653.468:230): avc:  denied  { read } for  pid=3492 comm="system-config-k" name="my.cnf" dev="sda3" ino=1310937 scontext=system_u:system_r:kdumpgui_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mysqld_etc_t:s0 tclass=file
:type=SYSCALL msg=audit(1349647653.468:230): arch=x86_64 syscall=open success=no exit=EACCES a0=7fffcb164780 a1=0 a2=1b6 a3=238 items=0 ppid=3491 pid=3492 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=system-config-k exe=/usr/bin/python2.7 subj=system_u:system_r:kdumpgui_t:s0-s0:c0.c1023 key=(null)
:Hash: system-config-k,kdumpgui_t,mysqld_etc_t,file,read
:#============= kdumpgui_t ==============
:allow kdumpgui_t mysqld_etc_t:file read;
:audit2allow -R
:#============= kdumpgui_t ==============
:allow kdumpgui_t mysqld_etc_t:file read;
Comment 1 Adam Joseph Cook 2012-10-07 18:10:05 EDT
Created attachment 623175 [details]
File: type
Comment 2 Adam Joseph Cook 2012-10-07 18:10:06 EDT
Created attachment 623176 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-08 04:34:18 EDT
*** Bug 863866 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2012-10-08 04:45:34 EDT

*** This bug has been marked as a duplicate of bug 863864 ***

Note You need to log in before you can comment on or make changes to this bug.