Bug 863875 - SELinux is preventing /usr/bin/python2.7 from using the 'dac_override' capabilities.
SELinux is preventing /usr/bin/python2.7 from using the 'dac_override' capabi...
Status: CLOSED DUPLICATE of bug 863864
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:528650fad827d5c5640fdb04820...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 18:19 EDT by Adam Joseph Cook
Modified: 2012-10-08 04:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 04:45:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-07 18:19 EDT, Adam Joseph Cook
no flags Details
File: auditoutput.txt (11.71 KB, text/plain)
2012-10-07 18:19 EDT, Adam Joseph Cook
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-07 18:19 EDT, Adam Joseph Cook
no flags Details

  None (edit)
Description Adam Joseph Cook 2012-10-07 18:19:26 EDT
Description of problem:
1. Attempted to run 'system-config-kdump'.
2. SELinux raised this issue.


Additional info:
libreport version: 2.0.15
kernel:         3.6.0-3.fc18.x86_64

description:
:SELinux is preventing /usr/bin/python2.7 from using the 'dac_override' capabilities.
:
:*****  Plugin dac_override (91.4 confidence) suggests  ***********************
:
:If you want to help identify if domain needs this access or you have a file with the wrong permissions on your system
:Then turn on full auditing to get path information about the offending file and generate the error again.
:Do
:
:Turn on full auditing
:# auditctl -w /etc/shadow -p w
:Try to recreate AVC. Then execute
:# ausearch -m avc -ts recent
:If you see PATH record check ownership/permissions on file, and fix it, 
:otherwise report as a bugzilla.
:
:*****  Plugin catchall (9.59 confidence) suggests  ***************************
:
:If you believe that python2.7 should have the dac_override capability by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep system-config-k /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:kdumpgui_t:s0-s0:c0.c1023
:Target Context                system_u:system_r:kdumpgui_t:s0-s0:c0.c1023
:Target Objects                /etc/gshadow- [ capability ]
:Source                        system-config-k
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-13.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-3.fc18.x86_64 #1 SMP Wed Oct
:                              3 13:29:15 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-07 17:15:47 CDT
:Last Seen                     2012-10-07 17:15:47 CDT
:Local ID                      6fc8c866-9f0d-46d0-9048-769ec0bb96bb
:
:Raw Audit Messages
:type=AVC msg=audit(1349648147.225:241): avc:  denied  { dac_override } for  pid=3928 comm="system-config-k" capability=1  scontext=system_u:system_r:kdumpgui_t:s0-s0:c0.c1023 tcontext=system_u:system_r:kdumpgui_t:s0-s0:c0.c1023 tclass=capability
:
:
:type=AVC msg=audit(1349648147.225:241): avc:  denied  { dac_read_search } for  pid=3928 comm="system-config-k" capability=2  scontext=system_u:system_r:kdumpgui_t:s0-s0:c0.c1023 tcontext=system_u:system_r:kdumpgui_t:s0-s0:c0.c1023 tclass=capability
:
:
:type=SYSCALL msg=audit(1349648147.225:241): arch=x86_64 syscall=open success=no exit=EACCES a0=7fff4dc39610 a1=0 a2=1b6 a3=238 items=1 ppid=3927 pid=3928 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=system-config-k exe=/usr/bin/python2.7 subj=system_u:system_r:kdumpgui_t:s0-s0:c0.c1023 key=(null)
:
:type=CWD msg=audit(1349648147.225:241): cwd=/
:
:type=PATH msg=audit(1349648147.225:241): item=0 name=/etc/gshadow- inode=1310744 dev=08:03 mode=0100000 ouid=0 ogid=0 rdev=00:00 obj=system_u:object_r:shadow_t:s0
:
:Hash: system-config-k,kdumpgui_t,kdumpgui_t,capability,dac_override
:
:audit2allow
:
:#============= kdumpgui_t ==============
:allow kdumpgui_t self:capability { dac_read_search dac_override };
:
:audit2allow -R
:
:#============= kdumpgui_t ==============
:allow kdumpgui_t self:capability { dac_read_search dac_override };
:
Comment 1 Adam Joseph Cook 2012-10-07 18:19:31 EDT
Created attachment 623177 [details]
File: type
Comment 2 Adam Joseph Cook 2012-10-07 18:19:32 EDT
Created attachment 623178 [details]
File: auditoutput.txt
Comment 3 Adam Joseph Cook 2012-10-07 18:19:34 EDT
Created attachment 623179 [details]
File: hashmarkername
Comment 4 Adam Joseph Cook 2012-10-07 18:20:17 EDT
Comment on attachment 623178 [details]
File: auditoutput.txt

Output of 'ausearch -m avc -ts recent'
Comment 5 Miroslav Grepl 2012-10-08 04:45:45 EDT

*** This bug has been marked as a duplicate of bug 863864 ***

Note You need to log in before you can comment on or make changes to this bug.