Bug 8639 - no entries for ^[OH and ^[OF in inputrc (xterm home/end)
Summary: no entries for ^[OH and ^[OF in inputrc (xterm home/end)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: setup (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-19 22:42 UTC by Hans de Goede
Modified: 2014-03-17 02:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-31 05:11:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my inputrc (523 bytes, patch)
2000-01-19 22:43 UTC, Hans de Goede
no flags Details | Diff

Description Hans de Goede 2000-01-19 22:42:50 UTC
The summary says it all,

I've attached my own inputrc as replacement, it just adds:

#for xterm
"\eOH": beginning-of-line
"\eOF": end-of-line

And it adds some comments on why most lines are there.

Comment 1 Hans de Goede 2000-01-19 22:43:59 UTC
Created attachment 71 [details]
my inputrc

Comment 2 Bill Nottingham 2000-01-19 23:02:59 UTC
Fixed in setup >= 2.1, which will be in the next Raw Hide.

Comment 3 Hans de Goede 2000-01-30 14:25:59 UTC
The fix in setup-2.1.3 is based upon a very old mail fo mine, sorry for the
confusion :| . I thought entering the newer version of my inputrc in bugzilla
would be enough.

I see 2 problems wiht this fix:
-it doesn't contain ^[[F / ^[[H for end / home, these are used by freebsd
 console and by a lott of broken xterm emulators. Telnetting from these
 will work better if these are present.
-at the time I wrote the mail on which the current fixed is based I still
 thought it was a good idea to bind true 8-bit meta chars for alt-b and -alt-f
 to word-backward / word-forward. Later I learned that this might bite
 international characters, since then trying to input a + ^ for example will
 result in word backward. So please remove the M- bindings, and add
 the ^[[F / ^[[H bindings, or use the inputrc attached to the bugreport,
 it is identical to the one in setup-2.1.3 accept:
 -it adds ^[[F / ^[[H
 -it removes the M- bindings.

Comment 4 Bill Nottingham 2000-01-31 05:11:59 UTC
Will be fixed in setup-2.1.4.


Note You need to log in before you can comment on or make changes to this bug.