Bug 863913 - Grabbing a disabled device crashes the server
Grabbing a disabled device crashes the server
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Peter Hutterer
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 23:35 EDT by Peter Hutterer
Modified: 2013-02-21 03:04 EST (History)
1 user (show)

See Also:
Fixed In Version: xorg-x11-server-1.13.0-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:04:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 54934 None None None 2012-10-07 23:35:20 EDT

  None (edit)
Description Peter Hutterer 2012-10-07 23:35:20 EDT
Description of problem:
An XI 1.x grab on a disabled device leads to a NULL-pointer dereference crashing the server.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.13.0-4.el6.x86_64

How reproducible:
Can be reproduced on a virtual machine (see example below), but same will happen with other devices

Steps to Reproduce:
1. xinput set-prop "ImEXPS/2 Generic Explorer Mouse" "Device Enabled" 0
2. start gimp, Edit, Preferences, Input Devices, Configure Extended Input Devices
3. change the QEMU tablet and the ImEXPS/2 mouse to mode "screen"
4. Open a canvas, click on the canvas.
  
Actual results:
On receiving the button event, the GIMP will grab all input devices with XGrabDevice(), causing a crash.

Additional info:
https://bugs.freedesktop.org/show_bug.cgi?id=54934
Comment 1 RHEL Product and Program Management 2012-10-07 23:38:58 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 3 Peter Hutterer 2012-10-10 01:10:09 EDT
MODIFIED

xorg-x11-server-1.13.0-5.el6 is available in brew
Comment 7 errata-xmlrpc 2013-02-21 03:04:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0299.html

Note You need to log in before you can comment on or make changes to this bug.