Bug 863917 - No way of telling whether your Zanata push worked
No way of telling whether your Zanata push worked
Status: CLOSED CANTFIX
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 00:03 EDT by Tim Hildred
Modified: 2013-07-01 18:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-01 18:56:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Hildred 2012-10-08 00:03:40 EDT
Description of problem:
When pushing topics to Zanata, there is no way to tell if your push has silently failed or silently succeeded. 

Expected results:
Message when pushing to Zanata says:
Successfully uploaded your topic to Zanata as Topicid-RevisionNumber

or 

Push to Zanata failed, please try again. If you are unable to successfully push your topic through to Zanata after two attempts, please contact ______@redhat.com.

Cite the following error:
_____ INSERT HELPFUL PRESSGANG ZANATA INTEGRATION ERROR MESSAGE HERE _____


Additional info:
Set severity to high because we've been burned once, and because there is a lot of human intervention involved in this integration already.
Comment 1 Zac Dover 2012-10-08 00:53:42 EDT
Boy would it be nice to have some indication of whether a push failed or succeeded.
Comment 2 Ruediger Landmann 2012-10-15 03:20:06 EDT
(In reply to comment #0)
> Description of problem:
> When pushing topics to Zanata, there is no way to tell if your push has
> silently failed or silently succeeded. 

Tim, can you please provide an example of when this has happened and what its impact was?
Comment 3 Lee Newson 2012-10-15 05:05:13 EDT
While I'm not Tim, I can partly give some data. We've only had this happen once so far (or that I'm aware of) and it was around the start of this month. The result was that ~30 topics (it seemed to be about every second topic) wasn't pushed to Zanata, however they were created as Translated Topics in Skynet. As such I manually had to go through and find which topics weren't successfully pushed and repush them.

As for the issue of the Translated Topics being created in Skynet this has been fixed as of Wednesday 10th of October. Now the Translated Topic won't be created unless it is successfully created in Zanata first. So the topics will show up in the build as if they haven't been pushed will make it easier to find.

As for this RFE we'll take a look at providing a way to view the results once our team is back from holidays, as I'm the only one here.
Comment 4 Lee Newson 2013-07-01 18:56:29 EDT
Since this functionality has been removed and all pushes are now done by the csprocessor, which does inform you if something has gone wrong. I'm going to close this as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.