Bug 863953 - Twinkle call crash - list_del corruption
Twinkle call crash - list_del corruption
Status: CLOSED DUPLICATE of bug 871078
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 03:32 EDT by Jan Kratochvil
Modified: 2012-11-20 06:54 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-20 06:15:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel crash messages via netconsole (157.71 KB, text/plain)
2012-10-08 03:33 EDT, Jan Kratochvil
no flags Details

  None (edit)
Description Jan Kratochvil 2012-10-08 03:32:10 EDT
Description of problem:
Twinkle call on notebook Lenovo X220 crashes my host.
It is F-16 with F-17 kernel (offtopic: because F-16 kernels suddenly reboot for me once a day without any netconsole message).

Version-Release number of selected component (if applicable):
kernel-3.5.5-2.fc17.x86_64

How reproducible:
Tried Twinkle call twice, twice crashed.

Steps to Reproduce:
Make Twinkle SIP call.

Actual results:
Locked up machine, messages attached:
WARNING: at lib/list_debug.c:59 __list_del_entry+0xa1/0xd0()
[<ffffffff810e6bf9>] handle_fasteoi_irq+0x59/0x100

Expected results:
Normal calls like with F-16 kernels.

Additional info:
The netconsole messages are somehow messed/corrupted, they repeat indefinitely so grabbed only some first 2000 lines of the dump.
Comment 1 Jan Kratochvil 2012-10-08 03:33:36 EDT
Created attachment 623322 [details]
kernel crash messages via netconsole
Comment 2 Stephen Tweedie 2012-10-31 10:41:02 EDT
Looks like the same problem as bug 871078 except F17/x86_64 rather than F16/i686: common pattern is list_del corruption with usb_hcd_unlink_urb_from_ep in the stack trace.
Comment 3 Stephen Tweedie 2012-11-20 06:15:38 EST
There's a fix built for f16/17/18 in bug 871078 that works for me.  Closing this one as a duplicate.

*** This bug has been marked as a duplicate of bug 871078 ***
Comment 4 Jan Kratochvil 2012-11-20 06:54:28 EST
Confirming kernel-3.6.7-1.fc16.x86_64 works for me with Twinkle.

Note You need to log in before you can comment on or make changes to this bug.