Bug 863963 - [US2816][fork] Unable to tail app logs via "rhc tail"
[US2816][fork] Unable to tail app logs via "rhc tail"
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: chris alfonso
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 03:59 EDT by joycezhang
Modified: 2016-01-31 21:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:49:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joycezhang 2012-10-08 03:59:49 EDT
Description of problem:
Unable to tail logs for any kinds of app, following error are shown:
# rhc tail jboseap 
Password: *

nil
**********
Could not find any files matching glob

Version-Release number of selected component (if applicable):
devenv_2295
client: built from fork_ami_US2597_US2599_US2813_US2817_US2872_US2816_US2814_209

How reproducible:
always

Steps to Reproduce:
1.Create an app
2.Tail app log:
# rhc tail jboseap 

  
Actual results:
Could not find any files matching glob

Expected results:
App log should be shown.

Additional info:
Comment 1 John (J5) Palmieri 2012-10-09 09:42:36 EDT
default glob most likely not set.  Assigning to Chris
Comment 2 chris alfonso 2012-10-09 16:08:19 EDT
The default glob is set, looking into the issue in more detail...
Comment 3 chris alfonso 2012-10-09 16:59:24 EDT
This fix is available on J5's fork.
https://github.com/J5/rhc/commits/commands-merge-master
Comment 4 chris alfonso 2012-10-09 16:59:40 EDT
fork_ami_US2597_US2599_US2813_US2817_US2872_US2816_US2814_213
Comment 5 joycezhang 2012-10-09 22:20:37 EDT
This bug has been verified and fixed. Please refer to the details as below:

Verified build:
rhc client built from fork_ami_US2597_US2599_US2813_US2817_US2872_US2816_US2814_213
devenv_2303

Verified steps:
1. Create an app
2. Tail app log:
#rhc tail app

Verified results:
It's fixed, app log are shown correctly as below:

# rhc tail jboseap
Password: *

==> jbosseap-6.0/logs/boot.log <==
22:18:56,689 INFO  [org.xnio.nio] XNIO NIO Implementation Version 3.0.4.GA-redhat-1
22:18:56,830 INFO  [org.jboss.remoting] JBoss Remoting version 3.2.8.GA-redhat-1
22:18:56,994 INFO  [org.jboss.as.configadmin] JBAS016200: Activating ConfigAdmin Subsystem
22:18:57,056 INFO  [org.jboss.as.clustering.jgroups] JBAS010260: Activating JGroups subsystem.
22:18:57,077 INFO  [org.jboss.as.security] JBAS013101: Activating Security Subsystem
22:18:57,079 INFO  [org.jboss.as.jacorb] JBAS016300: Activating JacORB Subsystem
22:18:57,087 INFO  [org.jboss.as.logging] JBAS011502: Removing bootstrap log handlers
22:18:57,050 INFO  [org.jboss.as.clustering.infinispan] JBAS010280: Activating Infinispan subsystem.
22:18:57,094 INFO  [org.jboss.as.naming] JBAS011800: Activating Naming Subsystem
22:18:57,085 INFO  [org.jboss.as.osgi] JBAS011906: Activating OSGi Subsystem

==> jbosseap-6.0/logs/server.log <==
2012/10/09 22:19:08,613 INFO  [org.hornetq.jms.server.recovery.RecoveryDiscovery] (MSC service thread 1-1) Starting RecoveryDiscovery on XARecoveryConfig [transportConfiguration = [org-hornetq-core-remoting-impl-invm-InVMConnectorFactory?server-id=0], discoveryConfiguration = null, username=null, password=null]
2012/10/09 22:19:08,927 INFO  [org.hornetq.jms.server.recovery.RecoveryDiscovery] (MSC service thread 1-1) RecoveryDiscovery started fine on XARecoveryConfig [transportConfiguration = [org-hornetq-core-remoting-impl-invm-InVMConnectorFactory?server-id=0], discoveryConfiguration = null, username=null, password=null]
2012/10/09 22:19:08,928 INFO  [org.hornetq.ra.HornetQResourceAdapter] (MSC service thread 1-1) HornetQ resource adaptor started



So mark it as Verified. Thanks.
Comment 6 chris alfonso 2012-10-10 16:47:49 EDT
*** Bug 863937 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.